diff mbox series

[bug#46868] gnu: dwl: Update to 0.2.

Message ID tencent_F816F69F938E7F7953C9736DD3264FEA5C06@qq.com
State Accepted
Headers show
Series [bug#46868] gnu: dwl: Update to 0.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Z572 March 2, 2021, 4:43 a.m. UTC

Comments

Nicolas Goaziou March 2, 2021, 8:32 a.m. UTC | #1
Hello,

Z572 <873216071@qq.com> writes:

> Subject: [PATCH] gnu: dwl: Update to 0.2.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 82b46c18bd96df3a759feecc4a6e4de4d0605852 Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Sun, 28 Feb 2021 00:10:41 +0800
Subject: [PATCH] gnu: dwl: Update to 0.2.

* gnu/packages/wm.scm (dwl): Update to 0.2.
[arguments]: Remove the install phase.
---
 gnu/packages/wm.scm | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a837e6d20b..e0c4d1db84 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1264,7 +1264,7 @@  project derived from the original Calm Window Manager.")
 (define-public dwl
   (package
     (name "dwl")
-    (version "0.1")
+    (version "0.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1273,7 +1273,7 @@  project derived from the original Calm Window Manager.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "18g2sx8cv54zl5iw5m9lzngrp6ra2pyp7c68qps2ava3brw9m0j2"))))
+                "0r5hsxpckkrq1y7bjfq58rlc5xy45z499rg628q3nh289978ail1"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
@@ -1283,12 +1283,7 @@  project derived from the original Calm Window Manager.")
         (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)            ; no configure
-         (replace 'install              ; no install target
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin")))
-               (install-file "dwl" bin)))))))
+         (delete 'configure))))         ; no configure
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-- 
2.30.1