diff mbox series

[bug#63905] gnu: thc-ipv6: Do not build with "-march=native".

Message ID tencent_E19594D7C66CCAA5866669FED1EA4C947B0A@qq.com
State New
Headers show
Series [bug#63905] gnu: thc-ipv6: Do not build with "-march=native". | expand

Commit Message

Z572 June 5, 2023, 11:52 a.m. UTC
* gnu/packages/networking.scm (thc-ipv6)[origin]: Add 'snippet'.
[properties]: New field.
---
 gnu/packages/networking.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)


base-commit: 940665301de4effd065d24c167f619286f2adf4c

Comments

Efraim Flashner June 6, 2023, 6:58 a.m. UTC | #1
Patch applied. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9dfc785f04..701d2caa50 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -59,6 +59,7 @@ 
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3097,7 +3098,10 @@  (define-public thc-ipv6
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "07kwika1zdq62s5p5z94xznm77dxjxdg8k0hrg7wygz50151nzmx"))))
+        (base32 "07kwika1zdq62s5p5z94xznm77dxjxdg8k0hrg7wygz50151nzmx"))
+       (modules '((guix build utils)))
+       (snippet '(substitute* '("Makefile")
+                   (("-march=native") "")))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -3126,6 +3130,7 @@  (define-public thc-ipv6
            libpcap
            openssl
            perl))
+    (properties '((tunable? . #t)))
     (home-page "https://github.com/vanhauser-thc/thc-ipv6")
     (synopsis "IPv6 security research toolkit")
     (description "The THC IPv6 Toolkit provides command-line tools and a library