diff mbox series

[bug#62324] gnu: Add emu8051.

Message ID tencent_DC0C1B5DF72049AE04D2D339F0178DB1C60A@qq.com
State New
Headers show
Series [bug#62324] gnu: Add emu8051. | expand

Commit Message

c4droid March 31, 2023, 6:48 a.m. UTC

Comments

宋文武 March 31, 2023, 11:33 a.m. UTC | #1
c4droid <c4droid@foxmail.com> writes:

>>From a9f8f4e71dc5270ab7cbfd6da74a3fc7b304e5b6 Mon Sep 17 00:00:00 2001
> From: c4droid <c4droid@foxmail.com>
> Date: Fri, 31 Mar 2023 14:46:50 +0800
> Subject: [PATCH] [PATCH] gnu: Add emu8051.
>
> ---
>  gnu/packages/embedded.scm | 39 +++++++++++++++++++++++++++++++++++++++
>  1 file changed, 39 insertions(+)

Hello, I think emu8051 should go to emulators.scm, it seems embedded.scm
are for tools working with real hardwares, while emulators.scm has
similiar packages like qtmips.

I have send an updated patch to move it into emulators.scm, also fixed
home-page, and add commit message for file changes:

  * gnu/packages/emulator.scm (emu8051): New variable.

Though I just nocited it should be emulators.scm (emu8051)..

Well, I decide to push now, thank you for the patch and reviewers for
the feedbacks!
diff mbox series

Patch

From a9f8f4e71dc5270ab7cbfd6da74a3fc7b304e5b6 Mon Sep 17 00:00:00 2001
From: c4droid <c4droid@foxmail.com>
Date: Fri, 31 Mar 2023 14:46:50 +0800
Subject: [PATCH] [PATCH] gnu: Add emu8051.

---
 gnu/packages/embedded.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 8d854c7..653e02a 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 c4droid <c4droid@foxmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1747,3 +1748,41 @@  (define-public ts4900-utils
 @item tssilomon
 @end itemize")
       (license license:bsd-2))))
+
+(define-public emu8051
+  (let ((commit "5dc681275151c4a5d7b85ec9ff4ceb1b25abd5a8")
+        (revision "1"))
+    (package
+      (name "emu8051")
+      (version (git-version "0.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jarikomppa/emu8051")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1xxmkcwvd5fjnhwbricafg4xvxvr8dxhfanyfp4rbksw37dgk2fx"))
+                (modules '((guix build utils)))
+                (snippet #~(begin
+                             ;; Replace LDFLAGS -lcurses to -lncurses
+                             (substitute* "Makefile"
+                               (("-lcurses") "-lncurses"))))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:tests? #f ;No test suite
+             #:make-flags #~(list (string-append "CC="
+                                                 #$(cc-for-target)))
+             #:phases #~(modify-phases %standard-phases
+                          (delete 'configure) ;No ./configure script
+                          (replace 'install
+                            ;; No installation procedure
+                            (lambda _
+                              (install-file "emu"
+                                            (string-append #$output "/bin")))))))
+      (inputs (list ncurses))
+      (home-page "https://github.comjarikomppa/emu8051")
+      (synopsis "8051/8052 emulator with curses-based UI")
+      (description "emu8051 is a simulator of the 8051/8052 microcontrollers.")
+      (license license:expat))))
-- 
2.39.2