diff mbox series

[bug#45232] gnu: Add python-pdftotext.

Message ID tencent_D8AC89BF411DA6F28E92935AFBCD8D54C407@qq.com
State Accepted
Headers show
Series [bug#45232] gnu: Add python-pdftotext. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Dec. 14, 2020, 3:34 a.m. UTC

diff mbox series

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index a06f351aae..817c6a27c8 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -309,6 +310,25 @@  When present, Poppler is able to correctly render CJK and Cyrillic text.")
 Poppler PDF rendering library.")
     (license license:lgpl2.1+)))
 
+(define python-pdftotext
+  (package
+    (name "python-pdftotext")
+    (version "2.1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pdftotext" version))
+       (sha256
+        (base32
+         "19la1cw1hmkcr8big04gm2dd5fw0y0z97g930aiy29s1gaqbiblq"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("poppler" ,poppler)))
+    (home-page "https://github.com/jalan/pdftotext")
+    (synopsis "Simple PDF text extraction")
+    (description "Simple PDF text extraction")
+    (license license:expat)))
+
 (define-public libharu
   (package
    (name "libharu")