diff mbox series

[bug#46015] Add xkeysnail.

Message ID tencent_CA5EFF487438CA654A766B4736755333B309@qq.com
State Accepted
Headers show
Series [bug#46015] Add xkeysnail. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Jan. 21, 2021, 10:40 a.m. UTC

Comments

Ludovic Courtès Jan. 29, 2021, 11:03 a.m. UTC | #1
Hi,

Z572 <873216071@qq.com> skribis:

>>From c8ffb0e96851e5642fa872f5ffc20d9e56d30fb7 Mon Sep 17 00:00:00 2001
> From: Zheng Junjie <873216071@qq.com>
> Date: Thu, 21 Jan 2021 18:36:16 +0800
> Subject: [PATCH 1/2] gnu: Add python-inotify-simple.
>
> ---
>  gnu/packages/python-xyz.scm | 33 ++++++++++++++++++++++++++++++++-
>  1 file changed, 32 insertions(+), 1 deletion(-)

Applied with a commit log and without the Python 2 variant (we no longer
add them).

>>From ff3e5c516f7cae4cff3037cde5d36d7f415727dd Mon Sep 17 00:00:00 2001
> From: Zheng Junjie <873216071@qq.com>
> Date: Thu, 21 Jan 2021 18:37:33 +0800
> Subject: [PATCH 2/2] gnu: Add xkeysnail.
>
> ---
>  gnu/packages/xdisorg.scm | 31 ++++++++++++++++++++++++++++++-
>  1 file changed, 30 insertions(+), 1 deletion(-)

[...]

> +    (propagated-inputs
> +     `(("python-six" ,python-six)
> +       ("python-appdirs" ,python-appdirs)
> +       ("python-evdev" ,python-evdev)
> +       ("python-inotify-simple" ,python-inotify-simple)
> +       ("python-xlib" ,python-xlib)))

Please use ‘wrap-script’ around the ‘xkeysnail’ executable instead of
propagating inputs.  That way, installing xkeysnail won’t “pollute” the
user profile with all these Python libraries.

> +    (license license:gpl3)))

Is it version-3-only or version-3-or-any-later-version?

Could you send an updated patch?

Thanks,
Ludo’.
Ludovic Courtès Jan. 29, 2021, 11:04 a.m. UTC | #2
Also, suggested synopsis/description, with full sentences:

    (synopsis "Keyboard remapping tool for the X11 environment")
    (description
     "Xkeysnail is an X environment keyboard remapping tool, featuring
high-level and flexible remapping mechanisms.  It affects the low-level
layers (evdev and uinput), making remapping work in almost all the places.")
diff mbox series

Patch

From ff3e5c516f7cae4cff3037cde5d36d7f415727dd Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Thu, 21 Jan 2021 18:37:33 +0800
Subject: [PATCH 2/2] gnu: Add xkeysnail.

---
 gnu/packages/xdisorg.scm | 31 ++++++++++++++++++++++++++++++-
 1 file changed, 30 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 26660b8bfa..9522a2ae23 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -42,7 +42,7 @@ 
 ;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -326,6 +326,35 @@  application.")
   (home-page "https://hluk.github.io/CopyQ/")
   (license license:gpl3+)))
 
+(define-public xkeysnail
+  (package
+    (name "xkeysnail")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "xkeysnail" version))
+       (sha256
+        (base32
+         "1xyqp6yqxcwmxaqj86qcsiz0ly7bwr0a2w835myz909irhip3ngf"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;test need /dev/uinput
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-appdirs" ,python-appdirs)
+       ("python-evdev" ,python-evdev)
+       ("python-inotify-simple" ,python-inotify-simple)
+       ("python-xlib" ,python-xlib)))
+    (home-page "https://github.com/mooz/xkeysnail")
+    (synopsis
+     "Keyboard remapping tool for X environment")
+    (description
+     "A X environment keyboard remapping tool. high-level and flexible remapping
+mechanisms.  Runs in low-level layer (evdev and uinput), making remapping work
+in almost all the places.")
+    (license license:gpl3)))
+
 (define-public xclip
   (package
     (name "xclip")
-- 
2.30.0