diff mbox series

[bug#63636,1/2] gnu: pcre2: Update to 10.42.

Message ID tencent_C7EA6056D19F850E6B396B094B6DCDE67906@qq.com
State New
Headers show
Series pcre2: update to 10.42. | expand

Commit Message

Z572 May 22, 2023, 3:48 a.m. UTC
* gnu/packages/pcre.scm (pcre2): Update to 10.42.
[arguments]: <#:configure-flags>: enable jit when target to riscv64.
---
 gnu/packages/pcre.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 7c53a27685..769738c3d5 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -93,7 +94,7 @@  (define-public pcre
 (define-public pcre2
   (package
     (name "pcre2")
-    (version "10.40")
+    (version "10.42")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/PCRE2Project/pcre2"
@@ -101,7 +102,7 @@  (define-public pcre2
                                   "/pcre2-" version ".tar.bz2"))
               (sha256
                (base32
-                "0s4x2l6g0sb9piwkr3sxqwdswz2g6bk1hhwngv0kv4w38wybir0l"))))
+                "0h78np8h3dxlmvqvpnj558x67267n08n9zsqncmlqapans6csdld"))))
     (build-system gnu-build-system)
     (inputs (list bzip2 readline zlib))
     (arguments
@@ -113,8 +114,7 @@  (define-public pcre2
                "--enable-pcre2-16"
                "--enable-pcre2-32"
                ;; pcre2_jit_test fails on powerpc32.
-               ;; riscv64-linux is an unsupported architecture.
-               #$@(if (or (target-ppc32?) (target-riscv64?))
+               #$@(if (target-ppc32?)
                       #~()
                       #~("--enable-jit"))
                "--disable-static")