diff mbox series

[bug#45285] gnu: Add ark.

Message ID tencent_BA8F4567A79CB4E4A9166A533995362BEF05@qq.com
State Accepted
Headers show
Series [bug#45285] gnu: Add ark. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Dec. 17, 2020, 5:11 a.m. UTC
> QWARN  : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
> QWARN  : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
> FAIL!  : ExtractTest::testExtraction(extract all entries from a xar archive with path) Compared values are not the same
>    Actual   (extractedEntriesCount)        : 0
>    Expected (expectedExtractedEntriesCount): 6
>    Loc: [/tmp/guix-build-ark-20.04.1.drv-0/ark-20.04.1/autotests/kerfuffle/extracttest.cpp(469)]

The tests fail.

Comments

Ludovic Courtès Dec. 21, 2020, 3:46 p.m. UTC | #1
Hi,

Z572 <873216071@qq.com> skribis:

>> QWARN  : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
>> QWARN  : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
>> FAIL!  : ExtractTest::testExtraction(extract all entries from a xar archive with path) Compared values are not the same
>>    Actual   (extractedEntriesCount)        : 0
>>    Expected (expectedExtractedEntriesCount): 6
>>    Loc: [/tmp/guix-build-ark-20.04.1.drv-0/ark-20.04.1/autotests/kerfuffle/extracttest.cpp(469)]
>
> The tests fail.

What you paste above sounds like there could be a real issue with some
archive formats, which may be a core issue for this archiving tool.

Could you investigate a bit and/or get in touch with upstream to see if
they can provide guidance?

> +    (home-page "https://apps.kde.org/en/ark")
> +    (synopsis "Archiving Tool")
> +    (description "Graphical file compression/decompression utility with support
> +for multiple formats.")

Please expound a bit and write pull sentences, as explained at:

  https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html

Could you send an updated patch once you know more about the issue
evidenced by the test suite?

Thanks in advance!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 2718acac9a..cf0305c355 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -41,6 +41,7 @@ 
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages apr)
   #:use-module (gnu packages audio)
+  #:use-module (gnu packages backup)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages code)
@@ -79,6 +80,56 @@ 
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public ark
+  (package
+    (name "ark")
+    (version "20.04.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/release-service/" version
+                                  "/src/ark-" version ".tar.xz"))
+
+              (sha256
+               (base32
+                "0g5bfa1lc7mhrc2ngd4ldf33dpwr7gqrj95kp897pf632wwj23iw"))))
+    (build-system qt-build-system)
+    (arguments
+     `(#:tests? #f
+       #:configure-flags
+       (list "-DBUILD_TESTING=OFF")))
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("pkg-config" ,pkg-config)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("breeze-icons" ,breeze-icons)
+       ("kdbusaddons" ,kdbusaddons)
+       ("kitemmodels" ,kitemmodels)
+       ("kparts" ,kparts)
+       ("kpty" ,kpty)
+       ("karchive" ,karchive)
+       ("kconfig" ,kconfig)
+       ("kcrash" ,kcrash)
+       ("khtml" ,khtml)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("qtbase" ,qtbase)
+       ("libarchive" ,libarchive)
+       ("libzip" ,libzip)
+       ("p7zip" ,p7zip)
+       ("zip" ,zip)
+       ;; ("unar" ,unar)
+       ("unzip" ,unzip)
+       ("lrzip" ,lrzip)
+       ("lzop" ,lzop)
+       ("zstd" ,zstd)
+       ("zlib" ,zlib)))
+    (home-page "https://apps.kde.org/en/ark")
+    (synopsis "Archiving Tool")
+    (description "Graphical file compression/decompression utility with support
+for multiple formats.")
+    (license license:gpl2+)))
+
 (define-public baloo-widgets
   (package
     (name "baloo-widgets")