diff mbox series

[bug#63919] gnu: guile-jsonld: fix build and use new style.

Message ID tencent_B3657336B536CBE54F4267B11CAAA4BF5605@qq.com
State New
Headers show
Series [bug#63919] gnu: guile-jsonld: fix build and use new style. | expand

Commit Message

Z572 June 6, 2023, 4:43 a.m. UTC
* gnu/packages/guile-xyz (guile-jsonld)
[propagated-inputs]: replace GNUTLS with GUILE-GNUTLS, use new style.
---
 gnu/packages/guile-xyz.scm | 37 ++++++++++++++++---------------------
 1 file changed, 16 insertions(+), 21 deletions(-)


base-commit: 8937898af9433c0b7a8d95a78c95e21576ae22e8

Comments

Nicolas Goaziou July 5, 2023, 10:57 p.m. UTC | #1
Hello,

Z572 via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/guile-xyz (guile-jsonld)
> [propagated-inputs]: replace GNUTLS with GUILE-GNUTLS, use new style.

I separated style and fix in two patches, then applied them. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index d8684bb818..0415d857e7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -43,7 +43,7 @@ 
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
-;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022, 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
@@ -4622,30 +4622,25 @@  (define-public guile-jsonld
   (package
     (name "guile-jsonld")
     (version "1.0.2")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://framagit.org/tyreunom/guile-jsonld")
-               (commit version)))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "1ryyvh71899z2inivqglb8d78zzp1sd0wv9a56kvcmrxf1966z6r"))))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://framagit.org/tyreunom/guile-jsonld")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1ryyvh71899z2inivqglb8d78zzp1sd0wv9a56kvcmrxf1966z6r"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f)); require network
-    (propagated-inputs
-     `(("guile-gnutls" ,gnutls)
-       ("guile-json" ,guile-json-4)
-       ("guile-rdf" ,guile-rdf)))
-    (inputs
-     (list guile-3.0))
-    (native-inputs
-     (list automake autoconf pkg-config texinfo))
+     (list #:tests? #f)) ;require network
+    (propagated-inputs (list guile-gnutls guile-json-4 guile-rdf))
+    (inputs (list guile-3.0))
+    (native-inputs (list automake autoconf pkg-config texinfo))
     (home-page "https://framagit.org/tyreunom/guile-jsonld")
     (synopsis "Guile implementation of the JsonLD API specification")
-    (description "Guile JsonLD is an implementation of the JsonLD (Json for
+    (description
+     "Guile JsonLD is an implementation of the JsonLD (Json for
 Linked Data) API defined by the W3C for GNU Guile.  It allows you to express links
 between data, in a way that is very similar to WikiData or RDF for instance.
 An object can have relations (in the form of an IRI) that relates it to one or