diff mbox series

[bug#46015] Add xkeysnail.

Message ID tencent_986545FDA5E938967B96ACD5626F4AA58E0A@qq.com
State Accepted
Headers show
Series [bug#46015] Add xkeysnail. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Jan. 29, 2021, 5:05 p.m. UTC

Comments

宋文武 Feb. 12, 2021, 9:50 a.m. UTC | #1
Z572 <873216071@qq.com> writes:

> Subject: [PATCH] gnu: Add xkeysnail.

Pushed, thank you!
diff mbox series

Patch

From e1e02b411e6314ecb491fd0980fdfbb94b6466ff Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Fri, 29 Jan 2021 23:06:25 +0800
Subject: [PATCH] gnu: Add xkeysnail.

* gnu/packages/xdisorg.scm (xkeysnail): New variable.
---
 gnu/packages/xdisorg.scm | 30 +++++++++++++++++++++++++++++-
 1 file changed, 29 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 26660b8bfa..a08eae247a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -42,7 +42,7 @@ 
 ;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -326,6 +326,34 @@  application.")
   (home-page "https://hluk.github.io/CopyQ/")
   (license license:gpl3+)))
 
+(define-public xkeysnail
+  (package
+    (name "xkeysnail")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "xkeysnail" version))
+       (sha256
+        (base32
+         "1xyqp6yqxcwmxaqj86qcsiz0ly7bwr0a2w835myz909irhip3ngf"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;tests need /dev/uinput
+    (inputs
+     `(("python-appdirs" ,python-appdirs)
+       ("python-evdev" ,python-evdev)
+       ("python-inotify-simple" ,python-inotify-simple)
+       ("python-xlib" ,python-xlib)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/mooz/xkeysnail")
+    (synopsis "Keyboard remapping tool for the X11 environment")
+    (description
+     "Xkeysnail is an X environment keyboard remapping tool, featuring
+high-level and flexible remapping mechanisms.  It affects the low-level
+layers (evdev and uinput), making remapping work in almost all the places.")
+    (license license:gpl3+)))           ; see README.md (no licence headers)
+
 (define-public xclip
   (package
     (name "xclip")
-- 
2.30.0