@@ -305,7 +305,7 @@ (define-public gnome-plots
(define-public gnome-shell-extension-appindicator
(package
(name "gnome-shell-extension-appindicator")
- (version "33")
+ (version "42")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -314,13 +314,11 @@ (define-public gnome-shell-extension-appindicator
(commit (string-append "v" version))))
(sha256
(base32
- "0qm77s080nbf4gqnfzpwp8a7jf7lliz6fxbsd3lasvrr11pgsk87"))
+ "1lf3aqb924nzhj87rhy2zvm5pcfqcklhfw21m6ic3i7wzd9r7cnc"))
(file-name (git-file-name name version))))
- (build-system copy-build-system)
- (arguments
- `(#:install-plan
- '(("." ,(string-append "share/gnome-shell/extensions/"
- "appindicatorsupport@rgcjonas.gmail.com")))))
+ (build-system meson-build-system)
+ (native-inputs (list jq gnu-gettext
+ `(,glib "bin")))
(synopsis "Adds KStatusNotifierItem support to GNOME Shell")
(description "This extension integrates Ubuntu AppIndicators
and KStatusNotifierItems (KDE's successor of the systray) into
From: tiantian <typ22@foxmail.com> * gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator): Update to 42. [build-system]: Switch to meson-build-system. [arguments]: Delete. [native-inputs]: New field. --- gnu/packages/gnome-xyz.scm | 12 +++++------- 1 file changed, 5 insertions(+), 7 deletions(-) base-commit: d1c6b8db5a30f9e428d018156dadb12927c485f8