diff mbox series

[bug#45223] gnu: Add ripgrep.

Message ID tencent_77ACAC83BF559DB7F2AC92F3DACBCDBA5407@qq.com
State Accepted
Headers show
Series [bug#45223] gnu: Add ripgrep. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Dec. 13, 2020, 2:05 p.m. UTC

Comments

John Soo Jan. 24, 2021, 6:42 p.m. UTC | #1
Hello,

We already have ripgrep in gnu/packages/rust-apps.scm.

Do you want to update that one instead of adding a new package please?

Thanks!

John
Z572 Jan. 25, 2021, 9:44 a.m. UTC | #2
Sorry, I sent an email to 45223-done@debbugs.gnu.org at December 17,
This thread should be closed.
宋文武 Feb. 12, 2021, 6:29 a.m. UTC | #3
Z572 <873216071@qq.com> writes:

> Sorry, I sent an email to 45223-done@debbugs.gnu.org at December 17,
> This thread should be closed.

It's still open now, let me try..

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6f71cf6398..d50473174f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2020 André Batista <nandre@riseup.net>
 ;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
+;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35488,3 +35489,413 @@  formatters with per-field documentation generated for each structure.
     (description
       "Generate Rust register maps (`struct`s) from SVD files")
     (license (list license:expat license:asl2.0))))
+
+(define-public rust-tabwriter-1
+  (package
+    (name "rust-tabwriter")
+    (version "1.2.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "tabwriter" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "048i0mj3b07zlry9m5fl706y5bzdzgrswymqn32drakzk7y5q81n"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-regex" ,rust-regex-1)
+         ("rust-unicode-width" ,rust-unicode-width-0.1))))
+    (home-page
+      "https://github.com/BurntSushi/tabwriter")
+    (synopsis "Elastic tabstops.")
+    (description "Elastic tabstops.")
+    (license (list license:unlicense license:expat))))
+
+(define-public rust-nom-2
+  (package
+    (name "rust-nom")
+    (version "2.2.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "nom" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1zv6ig7nw532rl4p35jsahglfhyyznjkblwa6si6c0plxhlsflfg"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-lazy-static" ,rust-lazy-static-0.2)
+         ("rust-regex" ,rust-regex-0.2))))
+    (home-page "https://github.com/Geal/nom")
+    (synopsis
+      "A byte-oriented, zero-copy, parser combinators library")
+    (description
+      "This package provides a byte-oriented, zero-copy, parser combinators library")
+    (license license:expat)))
+
+(define-public rust-tree-magic-fork-0.2
+  (package
+    (name "rust-tree-magic-fork")
+    (version "0.2.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "tree_magic_fork" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1bqkd17ih1ixlarjw8p5h5q584j681vmwg1zkww873w2kg523fda"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-clap" ,rust-clap-2)
+         ("rust-fnv" ,rust-fnv-1)
+         ("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-nom" ,rust-nom-2)
+         ("rust-num-cpus" ,rust-num-cpus-1)
+         ("rust-parking-lot" ,rust-parking-lot-0.8)
+         ("rust-petgraph" ,rust-petgraph-0.4)
+         ("rust-scoped-threadpool"
+          ,rust-scoped-threadpool-0.1)
+         ("rust-tabwriter" ,rust-tabwriter-1)
+         ("rust-walkdir" ,rust-walkdir-2))))
+    (home-page "https://github.com/phiresky/tree_magic")
+    (synopsis
+      "Determines the MIME type of a file by traversing a filetype tree.")
+    (description
+      "Determines the MIME type of a file by traversing a filetype tree.")
+    (license license:expat)))
+
+(define-public rust-size-format-1
+  (package
+    (name "rust-size-format")
+    (version "1.0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "size_format" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0fxjl0rc0x7yc14x885dh7jjf2jrlhpwf66akp3dxii246mzdmbf"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-generic-array" ,rust-generic-array-0.12)
+         ("rust-num" ,rust-num-0.2))))
+    (home-page "https://github.com/aticu/size_format")
+    (synopsis
+      "Allows for easier formatting of sizes.")
+    (description
+      "Allows for easier formatting of sizes.")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-indexmap-1
+  (package
+    (name "rust-indexmap")
+    (version "1.6.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "indexmap" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1wi8l3y2f3k4c2azaf3jm3pw2sksm90rzgv18x1a0lxacp3y9qjm"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-autocfg" ,rust-autocfg-1.0)
+         ("rust-hashbrown" ,rust-hashbrown-0.9)
+         ("rust-rayon" ,rust-rayon-1)
+         ("rust-serde" ,rust-serde-1))))
+    (home-page "https://github.com/bluss/indexmap")
+    (synopsis
+      "A hash table with consistent order and fast iteration.
+
+The indexmap is a hash table where the iteration order of the key-value
+pairs is independent of the hash values of the keys. It has the usual
+hash table functionality, it preserves insertion order except after
+removals, and it allows lookup of its elements by either hash table key
+or numerical index. A corresponding hash set type is also provided.
+
+This crate was initially published under the name ordermap, but it was renamed to
+indexmap.
+")
+    (description
+      "This package provides a hash table with consistent order and fast iteration.
+
+The indexmap is a hash table where the iteration order of the key-value
+pairs is independent of the hash values of the keys.  It has the usual
+hash table functionality, it preserves insertion order except after
+removals, and it allows lookup of its elements by either hash table key
+or numerical index.  A corresponding hash set type is also provided.
+
+This crate was initially published under the name ordermap, but it was renamed to
+indexmap.
+")
+    (license (list license:asl2.0 license:expat))))
+
+(define-public rust-serde-json-1
+  (package
+    (name "rust-serde-json")
+    (version "1.0.60")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "serde_json" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0yapc7xxk8dx12691yj0l13008rgvknmc6krvk8jwj7y4x6yh00m"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-indexmap" ,rust-indexmap-1)
+         ("rust-itoa" ,rust-itoa-0.4)
+         ("rust-ryu" ,rust-ryu-1.0)
+         ("rust-serde" ,rust-serde-1))))
+    (home-page "https://github.com/serde-rs/json")
+    (synopsis "A JSON serialization file format")
+    (description
+      "This package provides a JSON serialization file format")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-libsqlite3-sys-0.18
+  (package
+    (name "rust-libsqlite3-sys")
+    (version "0.18.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "libsqlite3-sys" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1ggpbnis0rci97ln628y2v6pkgfhb6zgc8rsp444mkdfph14lw0y"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-bindgen" ,rust-bindgen-0.53)
+         ("rust-cc" ,rust-cc-1)
+         ("rust-pkg-config" ,rust-pkg-config-0.3)
+         ("rust-vcpkg" ,rust-vcpkg-0.2))))
+    (home-page "https://github.com/rusqlite/rusqlite")
+    (synopsis
+      "Native bindings to the libsqlite3 library")
+    (description
+      "Native bindings to the libsqlite3 library")
+    (license license:expat)))
+
+(define-public rust-rusqlite-0.23
+  (package
+    (name "rust-rusqlite")
+    (version "0.23.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rusqlite" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "12z5584sylfqg7v2fyiycahyg0hf186v8v2ff5ad4qyzw5igvl25"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-bitflags" ,rust-bitflags-1)
+         ("rust-byteorder" ,rust-byteorder-1)
+         ("rust-chrono" ,rust-chrono-0.4)
+         ("rust-csv" ,rust-csv-1.1)
+         ("rust-fallible-iterator"
+          ,rust-fallible-iterator-0.2)
+         ("rust-fallible-streaming-iterator"
+          ,rust-fallible-streaming-iterator-0.1)
+         ("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-libsqlite3-sys" ,rust-libsqlite3-sys-0.18)
+         ("rust-lru-cache" ,rust-lru-cache-0.1)
+         ("rust-memchr" ,rust-memchr-2)
+         ("rust-serde-json" ,rust-serde-json-1)
+         ("rust-smallvec" ,rust-smallvec-1)
+         ("rust-time" ,rust-time-0.1)
+         ("rust-url" ,rust-url-2)
+         ("rust-uuid" ,rust-uuid-0.8))))
+    (home-page "https://github.com/rusqlite/rusqlite")
+    (synopsis "Ergonomic wrapper for SQLite")
+    (description "Ergonomic wrapper for SQLite")
+    (license license:expat)))
+
+(define-public rust-lmdb-rkv-sys-0.11
+  (package
+    (name "rust-lmdb-rkv-sys")
+    (version "0.11.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "lmdb-rkv-sys" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1994mvbdxkvq6c3z9npv1zjpvrhvpk9zry3azgyklyqn4nn70x5j"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-bindgen" ,rust-bindgen-0.53)
+         ("rust-cc" ,rust-cc-1)
+         ("rust-libc" ,rust-libc-0.2)
+         ("rust-pkg-config" ,rust-pkg-config-0.3))))
+    (home-page "https://github.com/mozilla/lmdb-rs")
+    (synopsis "Rust bindings for liblmdb.")
+    (description "Rust bindings for liblmdb.")
+    (license license:asl2.0)))
+
+(define-public rust-lmdb-rkv-0.14
+  (package
+    (name "rust-lmdb-rkv")
+    (version "0.14.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "lmdb-rkv" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0aylp9j3s34cgxfj3dszcnplj5a594ylykhgnpxrqafag9pjjyj4"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-bitflags" ,rust-bitflags-1)
+         ("rust-byteorder" ,rust-byteorder-1)
+         ("rust-libc" ,rust-libc-0.2)
+         ("rust-lmdb-rkv-sys" ,rust-lmdb-rkv-sys-0.11))))
+    (home-page "https://github.com/mozilla/lmdb-rs")
+    (synopsis "Idiomatic and safe LMDB wrapper.")
+    (description "Idiomatic and safe LMDB wrapper.")
+    (license license:asl2.0)))
+
+(define-public rust-rkv-0.10
+  (package
+    (name "rust-rkv")
+    (version "0.10.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rkv" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "14v7izkpwvk4ag8p9machzjq2v10xwimy5ylbra744wpyk0xp8rh"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-arrayref" ,rust-arrayref-0.3)
+         ("rust-bincode" ,rust-bincode-1)
+         ("rust-bitflags" ,rust-bitflags-1)
+         ("rust-byteorder" ,rust-byteorder-1)
+         ("rust-failure" ,rust-failure-0.1)
+         ("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-lmdb-rkv" ,rust-lmdb-rkv-0.14)
+         ("rust-ordered-float" ,rust-ordered-float-1.0)
+         ("rust-serde" ,rust-serde-1)
+         ("rust-serde-derive" ,rust-serde-derive-1)
+         ("rust-url" ,rust-url-2)
+         ("rust-uuid" ,rust-uuid-0.8))))
+    (home-page "https://github.com/mozilla/rkv")
+    (synopsis
+      "A simple, humane, typed key-value storage solution")
+    (description
+      "This package provides a simple, humane, typed key-value storage solution")
+    (license license:asl2.0)))
+
+(define-public rust-packed-simd-2-0.3
+  (package
+    (name "rust-packed-simd-2")
+    (version "0.3.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "packed_simd_2" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "05wsm2yxxpwww6a74hi8l80qszisfar5d7whf2pd87wn5x4y0y1j"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-cfg-if" ,rust-cfg-if-0.1)
+         ("rust-core-arch" ,rust-core-arch-0.1)
+         ("rust-libm" ,rust-libm-0.1)
+         ("rust-sleef-sys" ,rust-sleef-sys-0.1))))
+    (home-page
+      "https://github.com/rust-lang-nursery/packed_simd")
+    (synopsis "Portable Packed SIMD vectors")
+    (description "Portable Packed SIMD vectors")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-encoding-rs-0.8
+  (package
+    (name "rust-encoding-rs")
+    (version "0.8.26")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "encoding_rs" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "10xjcafwbxvm2kfsyymxlz8wc9s4bmdj1xzlc809rxyp2yrbl6w0"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-cfg-if" ,rust-cfg-if-1)
+         ("rust-packed-simd-2" ,rust-packed-simd-2-0.3)
+         ("rust-serde" ,rust-serde-1))))
+    (home-page "https://docs.rs/encoding_rs/")
+    (synopsis
+      "A Gecko-oriented implementation of the Encoding Standard")
+    (description
+      "This package provides a Gecko-oriented implementation of the Encoding Standard")
+    (license (list license:asl2.0 license:expat))))
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index c3d1d3bb26..9053ce2608 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,7 +37,10 @@ 
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages tls)
-  #:use-module (gnu packages version-control))
+  #:use-module (gnu packages version-control)
+  #:use-module (gnu packages pdf)
+  #:use-module (gnu packages haskell-xyz)
+  #:use-module (gnu packages base))
 
 (define-public bat
   (package
@@ -341,6 +345,69 @@  your current directory for a regex pattern while respecting your
 gitignore rules.")
     (license (list license:unlicense license:expat))))
 
+(define-public ripgrep-all
+  (package
+    (name "ripgrep-all")
+    (version "0.9.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "ripgrep-all" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1ppci77wdyxz21mn7qd3pphl3pcl2q9kf1ravc9a9zmv2r9n5gk1"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-bincode" ,rust-bincode-1)
+         ("rust-bzip2" ,rust-bzip2-0.3)
+         ("rust-cachedir" ,rust-cachedir-0.1)
+         ("rust-chrono" ,rust-chrono-0.4)
+         ("rust-clap" ,rust-clap-2)
+         ("rust-crossbeam" ,rust-crossbeam-0.7)
+         ("rust-encoding-rs" ,rust-encoding-rs-0.8)
+         ("rust-encoding-rs-io" ,rust-encoding-rs-io-0.1)
+         ("rust-env-logger" ,rust-env-logger-0.7)
+         ("rust-exitfailure" ,rust-exitfailure-0.5)
+         ("rust-failure" ,rust-failure-0.1)
+         ("rust-flate2" ,rust-flate2-1)
+         ("rust-glob" ,rust-glob-0.3)
+         ("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-log" ,rust-log-0.4)
+         ("rust-paste" ,rust-paste-0.1)
+         ("rust-path-clean" ,rust-path-clean-0.1)
+         ("rust-regex" ,rust-regex-1)
+         ("rust-rkv" ,rust-rkv-0.10)
+         ("rust-rusqlite" ,rust-rusqlite-0.23)
+         ("rust-serde" ,rust-serde-1)
+         ("rust-serde-json" ,rust-serde-json-1)
+         ("rust-size-format" ,rust-size-format-1)
+         ("rust-structopt" ,rust-structopt-0.3)
+         ("rust-tar" ,rust-tar-0.4)
+         ("rust-tempfile" ,rust-tempfile-3)
+         ("rust-tree-magic-fork"
+          ,rust-tree-magic-fork-0.2)
+         ("rust-xz2" ,rust-xz2-0.1)
+         ("rust-zip" ,rust-zip-0.5)
+         ("rust-zstd" ,rust-zstd-0.5))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("xz" ,xz)))
+    (propagated-inputs
+     `(("pandoc" ,pandoc)
+       ("poppler" ,poppler)
+       ("zip" ,zip)
+       ("tar" ,tar)))
+    (home-page
+      "https://github.com/phiresky/ripgrep-all")
+    (synopsis
+      "rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc.")
+    (description
+      "rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc.")
+    (license license:agpl3)))
+
 (define-public rust-cbindgen
   (package
     (name "rust-cbindgen")