diff mbox series

[bug#45739] Add chili-sddm-theme.

Message ID tencent_7375D3203529EBEE0F5CA7A4FCA864AEF605@qq.com
State Accepted
Headers show
Series [bug#45739] Add chili-sddm-theme. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Jan. 9, 2021, 12:15 p.m. UTC

Comments

Ludovic Courtès Feb. 24, 2021, 11:11 p.m. UTC | #1
Hi,

Z572 <873216071@qq.com> skribis:

> +(define-public chili-sddm-theme
> +  (package
> +    (name "chili-sddm-theme")

I change the license to gpl3+ (that’s what the .qml files say), added a
commit log, and committed on your behalf.

In the future, please use ‘git format-patch’:

  https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index b6e5ab7d19..db66f6d00d 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2020 L  p R n  d n <guix@lprndn.info>
 ;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -158,6 +159,36 @@  Guix's logo.  Based on Arch linux's archlinux-simplyblack theme.")
     ;; Theme under cc-by-sa3.0, guix logo under license:cc-by-sa4.0
     (license (list license:cc-by-sa3.0 license:cc-by-sa4.0))))
 
+(define-public chili-sddm-theme
+  (package
+    (name "chili-sddm-theme")
+    (version "0.1.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/MarianArlt/sddm-chili")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "036fxsa7m8ymmp3p40z671z163y6fcsa9a641lrxdrw225ssq5f3"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let* ((out (assoc-ref %outputs "out"))
+                (sddm-themes (string-append out "/share/sddm/themes")))
+           (mkdir-p sddm-themes)
+           (copy-recursively (assoc-ref %build-inputs "source")
+                             (string-append sddm-themes "/chili"))))))
+    (home-page "https://github.com/MarianArlt/sddm-chili")
+    (synopsis "Chili theme for SDDM")
+    (description "Chili reduces all the clutter and leaves you with a clean,
+easy to use, login interface with a modern yet classy touch.")
+    (license license:gpl3)))
+
 (define-public lightdm
   (package
     (name "lightdm")