diff mbox series

[bug#48065,14/14] gnu: Add zoxide.

Message ID tencent_5724EBE86F47E7ABFCAC24B9566EB327B505@qq.com
State Accepted
Headers show
Series [bug#48065,01/14] gnu: Add rust-ordered-float-2. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Z572 April 27, 2021, 4:12 p.m. UTC
From: Zheng junjie <873216071@qq.com>

* gnu/packages/rust-apps.scm (zoxide): New variable.
---
 gnu/packages/rust-apps.scm | 41 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Nicolas Goaziou May 26, 2021, 1:24 p.m. UTC | #1
Hello,

Zheng Junjie <873216071@qq.com> writes:

> * gnu/packages/rust-apps.scm (zoxide): New variable.

Thank you.

> +    (synopsis
> +     "A faster way to navigate your filesystem")
> +    (description
> +     "@command{zoxide} is a blazing fast replacement for your cd command. It
> +keeps track of the directories you use most frequently, and uses a ranking
> +algorithm to navigate to the best match.")

I removed buzzwords from the synopsis and description, and applied the
patch set.

Note that upstream released 0.7.0, if you feel like upgrading it.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index dc9526b267..4e654c86ca 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -801,3 +801,44 @@  the details of how it was triggered.
 library and a dynamic library, and a C header to be used by any C (and
 C-compatible) software.")
     (license license:expat)))
+
+(define-public zoxide
+  (package
+    (name "zoxide")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "zoxide" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1ih01l3xp8plicxhmyxjkq12ncpdb8954jcj3dh3lwvkhvw29nkk"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-anyhow" ,rust-anyhow-1)
+        ("rust-askama" ,rust-askama-0.10)
+        ("rust-bincode" ,rust-bincode-1)
+        ("rust-clap" ,rust-clap-3)
+        ("rust-dirs-next" ,rust-dirs-next-2)
+        ("rust-dunce" ,rust-dunce-1)
+        ("rust-glob" ,rust-glob-0.3)
+        ("rust-once-cell" ,rust-once-cell-1)
+        ("rust-ordered-float" ,rust-ordered-float-2)
+        ("rust-rand" ,rust-rand-0.7)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-tempfile" ,rust-tempfile-3))
+       #:cargo-development-inputs
+       (("rust-assert-cmd" ,rust-assert-cmd-1)
+        ("rust-seq-macro" ,rust-seq-macro-0.2))))
+    (home-page
+     "https://github.com/ajeetdsouza/zoxide/")
+    (synopsis
+     "A faster way to navigate your filesystem")
+    (description
+     "@command{zoxide} is a blazing fast replacement for your cd command. It
+keeps track of the directories you use most frequently, and uses a ranking
+algorithm to navigate to the best match.")
+    (license license:expat)))