diff mbox series

[bug#45075] gnu: Add hsetroot.

Message ID tencent_52D45E6D36A55667ADFC7DEAA0944B97900A@qq.com
State Accepted
Headers show
Series [bug#45075] gnu: Add hsetroot. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Dec. 6, 2020, 2:49 p.m. UTC

diff mbox series

Patch

From ee9f7740d38c03d4331a971dcd2dc0df327d5a6c Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Sun, 6 Dec 2020 21:36:11 +0800
Subject: [PATCH 1/1] gnu: Add hsetroot.

---
 gnu/packages/xorg.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index e64ffb58fc..9032f418c6 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -26,6 +26,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
+;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4495,6 +4496,47 @@  a display running X server.")
     (license license:x11)))
 
 
+(define-public hsetroot
+  (package
+    (name "hsetroot")
+    (version "1.0.5")
+    (home-page "https://github.com/himdel/hsetroot")
+    (source (origin
+              (method git-fetch)
+              (file-name (git-file-name name version))
+              (uri (git-reference
+                    (url home-page)
+                    (commit version)))
+              (sha256
+               (base32
+                "1jbk5hlxm48zmjzkaq5946s58rqwg1v1ds2sdyd2ba029hmvr722"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:make-flags
+       (list
+        "CC=gcc"
+        (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (add-before 'install 'mkdir-install-path
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (mkdir-p (string-append out "/bin"))))))))
+    (inputs
+     `(("libx11" ,libx11)
+       ("imlib2" ,imlib2)
+       ("libxinerama" ,libxinerama)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (synopsis "Imlib2-based wallpaper changer")
+    (description
+     "A tool which allows you to compose wallpapers for X.
+  A fork of hsetroot by Hyriand.")
+    (license license:gpl2)))
+
+
 (define-public xtrans
   (package
     (name "xtrans")
-- 
2.29.2