diff mbox series

[bug#59726,1/2] gnu: g-wrap: Build with Guile 3.0.

Message ID tencent_3816FE1F9A0E6E7947095C2DDDE6742A5606@qq.com
State New
Headers show
Series gnu: g-wrap: Build with Guile 3.0. | expand

Commit Message

Z572 Nov. 30, 2022, 4:29 p.m. UTC
* gnu/packages/guile-xyz.scm(g-wrap)[source]: Modify configure to add Guile
3.0 support. move Modify configure guilemoduledir to it. dons't use removed
api.

[inputs]: add Guile 3.0, indent.
[native-inputs]: add Guile 3.0.
[propagated-inputs]: add libffi, remove guile-2.2.
[arguments]:
<#:configure-flags>: remove it.
<#:parallel-build?>: set it to #f.
<#:make-flags>: set it to '("GUILE_AUTO_COMPILE=0)".
<#:phases>: add set-indent-program-path phase, remove pre-configure phase.
---
 gnu/packages/guile-xyz.scm | 51 ++++++++++++++++++++++++++------------
 1 file changed, 35 insertions(+), 16 deletions(-)

Comments

Ludovic Courtès Dec. 2, 2022, 10:03 p.m. UTC | #1
Hi,

Z572 <873216071@qq.com> skribis:

> * gnu/packages/guile-xyz.scm(g-wrap)[source]: Modify configure to add Guile
> 3.0 support. move Modify configure guilemoduledir to it. dons't use removed
> api.
>
> [inputs]: add Guile 3.0, indent.
> [native-inputs]: add Guile 3.0.
> [propagated-inputs]: add libffi, remove guile-2.2.
> [arguments]:
> <#:configure-flags>: remove it.
> <#:parallel-build?>: set it to #f.
> <#:make-flags>: set it to '("GUILE_AUTO_COMPILE=0)".
> <#:phases>: add set-indent-program-path phase, remove pre-configure phase.

G-Wrap has only one user, Guile-GNOME, which is stuck on Guile 2.2.
Thus I think G-Wrap has to remain on 2.2.

Besides, G-Wrap has been unmaintained for some time and there are other,
more convenient ways to write bindings these days.  I think we can leave
it as is.

Thoughts?

Ludo’.
Z572 Dec. 3, 2022, 9:04 a.m. UTC | #2
ok. close.

Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Z572 <873216071@qq.com> skribis:
>
>> * gnu/packages/guile-xyz.scm(g-wrap)[source]: Modify configure to add Guile
>> 3.0 support. move Modify configure guilemoduledir to it. dons't use removed
>> api.
>>
>> [inputs]: add Guile 3.0, indent.
>> [native-inputs]: add Guile 3.0.
>> [propagated-inputs]: add libffi, remove guile-2.2.
>> [arguments]:
>> <#:configure-flags>: remove it.
>> <#:parallel-build?>: set it to #f.
>> <#:make-flags>: set it to '("GUILE_AUTO_COMPILE=0)".
>> <#:phases>: add set-indent-program-path phase, remove pre-configure phase.
>
> G-Wrap has only one user, Guile-GNOME, which is stuck on Guile 2.2.
> Thus I think G-Wrap has to remain on 2.2.
>
> Besides, G-Wrap has been unmaintained for some time and there are other,
> more convenient ways to write bindings these days.  I think we can leave
> it as is.
>
> Thoughts?
>
> Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b1620618eb..a0b5964072 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -71,6 +71,7 @@  (define-module (gnu packages guile-xyz)
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages code)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages databases)
@@ -2135,25 +2136,43 @@  (define-public g-wrap
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0ak0bha37dfpj9kmyw1r8fj8nva639aw5xr66wr5gd3l1rqf5xhg"))))
+                "0ak0bha37dfpj9kmyw1r8fj8nva639aw5xr66wr5gd3l1rqf5xhg"))
+              (modules '((guix build utils)))
+              (snippet '(begin
+                          ;; allow guile 3.0
+                          (substitute* "configure"
+                            (("2\\.2 2\\.0")
+                             "3.0 2.2 2.0"))
+                          (substitute* (find-files "." "^Makefile.in$")
+                            (("guilemoduledir =.*guile/site" all)
+                             (string-append all "/@GUILE_EFFECTIVE_VERSION@")))
+                          ;; don't use removed api
+                          (substitute* "guile/g-wrap/guile-runtime.c"
+                            (("scm_class_([a-z]+)" all first)
+                             (string-append
+                              "scm_c_public_ref(\"oop goops\",\"<"
+                              first ">\")"))
+                            (("scm_memory_error\\(func_name\\)")
+                             "scm_report_out_of_memory()"))))))
     (build-system gnu-build-system)
-    (native-inputs
-     (list pkg-config))
+    (native-inputs (list pkg-config guile-3.0))
     (propagated-inputs
-     (list guile-2.2 guile-lib))
-    (inputs
-     (list libffi))
+     (list guile-lib
+           ;; Required by pc file
+           libffi))
+    (inputs (list libffi indent guile-3.0))
     (arguments
-     `(#:configure-flags '("--disable-Werror")
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'pre-configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (substitute* (find-files "." "^Makefile.in$")
-                 (("guilemoduledir =.*guile/site" all)
-                  (string-append all "/@GUILE_EFFECTIVE_VERSION@")))
-               #t))))))
+     `(#:parallel-build? #f ;not supported
+       ;; TODO: compile go files.
+       #:make-flags '("GUILE_AUTO_COMPILE=0")
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'set-indent-program-path
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (substitute* "g-wrap/util.scm"
+                        (("indent \\~S")
+                         (string-append (search-input-file inputs
+                                                           "/bin/indent")
+                                        " ~S"))))))))
     (synopsis "Generate C bindings for Guile")
     (description "G-Wrap is a tool and Guile library for generating function
 wrappers for inter-language calls.  It currently only supports generating Guile