diff mbox series

[bug#63636,2/2] gnu: pcre2: use git source.

Message ID tencent_308A6B7F3627535DB222FE1C7440CAAF4B09@qq.com
State New
Headers show
Series pcre2: update to 10.42. | expand

Commit Message

Z572 May 22, 2023, 3:48 a.m. UTC
* gnu/packages/pcre.scm[source]: use GIT-FETCH.
[native-inputs]: add AUTOCONF AUTOMAKE LIBTOOL.
---
 gnu/packages/pcre.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

Comments

Maxim Cournoyer Jan. 22, 2024, 4:32 a.m. UTC | #1
Hi,

Z572 <873216071@qq.com> writes:

> * gnu/packages/pcre.scm[source]: use GIT-FETCH.
> [native-inputs]: add AUTOCONF AUTOMAKE LIBTOOL.

I've pushed the update in 388bdc495d, but not the switch to git fetch as
this would increase the closure of core packages such as grep.

That would need to be investigated whether it'd cause a bootstrapping
problem.
diff mbox series

Patch

diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 769738c3d5..84ca7292b4 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -28,12 +28,14 @@ 
 
 (define-module (gnu packages pcre)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages)
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu))
@@ -96,14 +98,17 @@  (define-public pcre2
     (name "pcre2")
     (version "10.42")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/PCRE2Project/pcre2"
-                                  "/releases/download/pcre2-" version
-                                  "/pcre2-" version ".tar.bz2"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/PCRE2Project/pcre2")
+                    (commit (string-append "pcre2-" version))))
+              (file-name
+               (git-file-name name version))
               (sha256
                (base32
-                "0h78np8h3dxlmvqvpnj558x67267n08n9zsqncmlqapans6csdld"))))
+                "1d2kiavdn0wyxv168sz9wd77m3hl46i51fmx4pqya99ydnimpxzb"))))
     (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool))
     (inputs (list bzip2 readline zlib))
     (arguments
      (list #:configure-flags