diff mbox series

[bug#45427] Add kmenuedit.

Message ID tencent_2AEA4F47E7B8DCAD04AD5662F320D531EB05@qq.com
State New
Headers show
Series [bug#45427] Add kmenuedit. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Dec. 25, 2020, 12:17 p.m. UTC

diff mbox series

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 33b702539b..54952dc9dc 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -106,6 +107,35 @@  These window decorations can be used by for example an X11 based window
 manager which re-parents a Client window to a window decoration frame.")
     (license license:lgpl3+)))
 
+(define-public kmenuedit
+  (package
+    (name "kmenuedit")
+    (version "5.18.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/plasma/" version
+                                  "/kmenuedit-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1xnmmzw8wph0nxkzsfbfwribz9zc6szgagyl6ll2sri146brinar"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("kdbusaddons" ,kdbusaddons)
+       ("kiconthemes" ,kiconthemes)
+       ("sonnet" ,sonnet)
+       ("kinit" ,kinit)
+       ("kglobalaccel" ,kglobalaccel)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)))
+    (home-page "https://invent.kde.org/plasma/kmenuedit")
+    (synopsis "KDE menu editor")
+    (description "KDE menu editor.")
+    (license license:gpl2+)))
+
 (define-public kscreenlocker
   (package
     (name "kscreenlocker")