diff mbox series

[bug#45446] Add ktimer.

Message ID tencent_2A677FCA3AC7E500251BB5B29B5BA9FC5908@qq.com
State New
Headers show
Series [bug#45446] Add ktimer. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Dec. 26, 2020, 1 p.m. UTC

diff mbox series

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b1b8b6a484..a626999a0c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -685,6 +685,34 @@  communicate with each other.  Here's a few things KDE Connect can do:
 charts.")
     (license license:lgpl2.1+)))
 
+(define-public ktimer
+  (package
+    (name "ktimer")
+    (version "20.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/release-service/" version
+                                  "/src/ktimer-" version ".tar.xz"))
+              (sha256
+               (base32
+                "12fz5v5ky03h18jl75fnq1zagjq8qzi1s1q7phjz5d1rbhwc57ls"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("kdbusaddons" ,kdbusaddons)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("knotifications" ,knotifications)
+       ("qtbase" ,qtbase)))
+    (home-page "https://kde.org/applications/utilities/ktimer")
+    (synopsis "Countdown Launcher")
+    (description "KTimer is a little tool to execute programs after some time.
+It allows you to enter several tasks and to set a timer for each of them.  The
+timers for each task can be started, stopped, changed, or looped.")
+    (license license:gpl2+)))
+
 (define-public kcachegrind
   (package
     (name "kcachegrind")