[bug#78195] Remove unused use-module that can lead to circular dependencies
Commit Message
This change removes the use-module (gnu packages node-xyz) import from (gnu packages node).
node-xyz is not actually used in node and seems to have been accidentally added in f540ee5ef845946228c0e2e4cffadccd36069922.
Keeping it in can lead to circular dependency issues.
---
gnu/packages/node.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
base-commit: a6b40f7a2f2db3107319d1a5e099b269a462a723
--
2.49.0
@@ -13,7 +13,7 @@
;;; Copyright © 2021, 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2024 Daniel Khodabakhsh <d.khodabakhsh@gmail.com>
+;;; Copyright © 2024, 2025 Daniel Khodabakhsh <d@niel.khodabakh.sh>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,7 +50,6 @@ (define-module (gnu packages node)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
#:use-module (gnu packages networking)
- #:use-module (gnu packages node-xyz)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)