[bug#78195] Remove unused use-module that can lead to circular dependencies

Message ID tencent_228246984A5720429FC9550E91B52EC9E405@qq.com
State New
Headers
Series [bug#78195] Remove unused use-module that can lead to circular dependencies |

Commit Message

Dan Khodabakhsh May 1, 2025, 4:11 p.m. UTC
  This change removes the use-module (gnu packages node-xyz) import from (gnu packages node).
node-xyz is not actually used in node and seems to have been accidentally added in f540ee5ef845946228c0e2e4cffadccd36069922.
Keeping it in can lead to circular dependency issues.


---
 gnu/packages/node.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)




base-commit: a6b40f7a2f2db3107319d1a5e099b269a462a723
-- 
2.49.0
  

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 018a6b1bd0..4cad70a179 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -13,7 +13,7 @@ 
&nbsp;;;; Copyright © 2021, 2022 Philip McGrath <philip@philipmcgrath.com&gt;
&nbsp;;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space&gt;
&nbsp;;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il&gt;
-;;; Copyright © 2024 Daniel Khodabakhsh <d.khodabakhsh@gmail.com&gt;
+;;; Copyright © 2024, 2025 Daniel Khodabakhsh <d@niel.khodabakh.sh&gt;
&nbsp;;;;
&nbsp;;;; This file is part of GNU Guix.
&nbsp;;;;
@@ -50,7 +50,6 @@  (define-module (gnu packages node)
&nbsp; &nbsp;#:use-module (gnu packages libevent)
&nbsp; &nbsp;#:use-module (gnu packages linux)
&nbsp; &nbsp;#:use-module (gnu packages networking)
- &nbsp;#:use-module (gnu packages node-xyz)
&nbsp; &nbsp;#:use-module (gnu packages perl)
&nbsp; &nbsp;#:use-module (gnu packages pkg-config)
&nbsp; &nbsp;#:use-module (gnu packages python)