diff mbox series

[bug#64798,015/209] gnu: kcoreaddons: use G-expressions.

Message ID tencent_1CA7BD1CAD84A63676F3371530EBEF8F4305@qq.com
State New
Headers show
Series update kde package and add plasme desktop | expand

Commit Message

Z572 July 23, 2023, 8:21 a.m. UTC
* gnu/packages/kde-frameworks.scm (kcoreaddons)[arguments]:
Rewrite as G-expressions.
---
 gnu/packages/kde-frameworks.scm | 35 +++++++++++++++++----------------
 1 file changed, 18 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 7539e9807e..fe88629243 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -632,26 +632,27 @@  (define-public kcoreaddons
     (build-system cmake-build-system)
     (native-inputs
      (list extra-cmake-modules qttools-5 shared-mime-info))
-           ;; TODO: FAM: File alteration notification http://oss.sgi.com/projects/fam
+    ;; TODO: FAM: File alteration notification http://oss.sgi.com/projects/fam
     (inputs
      (list qtbase-5))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'blacklist-failing-test
-           (lambda _
-             ;; Blacklist failing tests.
-             (with-output-to-file "autotests/BLACKLIST"
-               (lambda _
-                 ;; FIXME: Make it pass.  Test failure caused by stout/stderr
-                 ;; being interleaved.
-                 (display "[test_channels]\n*\n")
-                 ;; FIXME
-                 (display "[test_inheritance]\n*\n")))))
-         (add-before 'check 'check-setup
-           (lambda _
-             (setenv "HOME" (getcwd))
-             (setenv "TMPDIR" (getcwd)))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'blacklist-failing-test
+            (lambda _
+              ;; Blacklist failing tests.
+              (with-output-to-file "autotests/BLACKLIST"
+                (lambda _
+                  ;; FIXME: Make it pass.  Test failure caused by stout/stderr
+                  ;; being interleaved.
+                  (display "[test_channels]\n*\n")
+                  ;; FIXME
+                  (display "[test_inheritance]\n*\n")))))
+          (add-before 'check 'check-setup
+            (lambda _
+              (setenv "HOME" (getcwd))
+              (setenv "TMPDIR" (getcwd)))))))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Qt addon library with a collection of non-GUI utilities")
     (description "KCoreAddons provides classes built on top of QtCore to