diff mbox series

[bug#61995] gnu: graphene: fix cross-compile.

Message ID tencent_1AFED4752CCB1B4AC66A83363D5381B2AC09@qq.com
State New
Headers show
Series [bug#61995] gnu: graphene: fix cross-compile. | expand

Commit Message

Z572 March 6, 2023, 6:50 a.m. UTC
* gnu/packages/gtk.scm(graphene): fix cross-compile.
[arguments]: <#:configure-flags>: use 'disabled' replace 'false' with
introspection option.
---
 gnu/packages/gtk.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Christopher Baines March 16, 2023, 6:43 p.m. UTC | #1
Z572 via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/gtk.scm(graphene): fix cross-compile.
> [arguments]: <#:configure-flags>: use 'disabled' replace 'false' with
> introspection option.
> ---
>  gnu/packages/gtk.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)

I've tweaked the commit message and pushed this to master as
1820dc7ce6945569db4ef6e265764705e6aabc48.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f575194c73..e985e161b1 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -34,6 +34,7 @@ 
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2516,7 +2517,7 @@  (define-public graphene
         "-Dinstalled_tests=false"
         ,@(if (%current-target-system)
               ;; Introspection requires running binaries for 'host' on 'build'.
-              '("-Dintrospection=false")
+              '("-Dintrospection=disabled")
               '()))))
     (native-inputs
      `(("git" ,git-minimal/pinned)