diff mbox series

[bug#59726,2/2] gnu: g-wrap: Use gexp.

Message ID tencent_0753B9B24EFEA27440CBBF4A606B37368F09@qq.com
State New
Headers show
Series gnu: g-wrap: Build with Guile 3.0. | expand

Commit Message

Z572 Nov. 30, 2022, 4:29 p.m. UTC
* gnu/packages/guile-xyz.scm (g-wrap): Use gexp.
---
 gnu/packages/guile-xyz.scm | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index a0b5964072..5560f3a98d 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2162,17 +2162,17 @@  (define-public g-wrap
            libffi))
     (inputs (list libffi indent guile-3.0))
     (arguments
-     `(#:parallel-build? #f ;not supported
-       ;; TODO: compile go files.
-       #:make-flags '("GUILE_AUTO_COMPILE=0")
-       #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'set-indent-program-path
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      (substitute* "g-wrap/util.scm"
-                        (("indent \\~S")
-                         (string-append (search-input-file inputs
-                                                           "/bin/indent")
-                                        " ~S"))))))))
+     (list #:parallel-build? #f ;not supported
+           ;; TODO: compile go files.
+           #:make-flags #~'("GUILE_AUTO_COMPILE=0")
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'set-indent-program-path
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (substitute* "g-wrap/util.scm"
+                              (("indent \\~S")
+                               (string-append (search-input-file inputs
+                                                                 "/bin/indent")
+                                              " ~S"))))))))
     (synopsis "Generate C bindings for Guile")
     (description "G-Wrap is a tool and Guile library for generating function
 wrappers for inter-language calls.  It currently only supports generating Guile