diff mbox series

[bug#49148] gnu: Add fnott.

Message ID tencent_0025A0B5C69BD7A92759407F193AF9E51A08@qq.com
State Accepted
Headers show
Series [bug#49148] gnu: Add fnott. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Z572 June 21, 2021, 3:50 a.m. UTC

Comments

Ludovic Courtès June 23, 2021, 9:31 p.m. UTC | #1
Hi,

Z572 <873216071@qq.com> skribis:

>>From 7497cedde15bf2e7ec60d31be1b511327cd165eb Mon Sep 17 00:00:00 2001
> From: Zheng junjie <873216071@qq.com>
> Date: Mon, 21 Jun 2021 11:40:30 +0800
> Subject: [PATCH] gnu: Add fnott.
>
> * gnu/packages/wm.scm (fnott): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 7497cedde15bf2e7ec60d31be1b511327cd165eb Mon Sep 17 00:00:00 2001
From: Zheng junjie <873216071@qq.com>
Date: Mon, 21 Jun 2021 11:40:30 +0800
Subject: [PATCH] gnu: Add fnott.

* gnu/packages/wm.scm (fnott): New variable.
---
 gnu/packages/wm.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c7a1c5a7ac..c686a70b93 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -82,6 +82,7 @@ 
   #:use-module (gnu packages bison)
   #:use-module (gnu packages build-tools) ;for meson-0.55
   #:use-module (gnu packages calendar)
+  #:use-module (gnu packages datastructures)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages fontutils)
@@ -908,6 +909,41 @@  experience.")
     (home-page "http://fluxbox.org/")
     (license license:expat)))
 
+(define-public fnott
+  (package
+    (name "fnott")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://codeberg.org/dnkl/fnott")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "13a0hb4wdbdlshzsj2r0d5zzvcy1jzs1hixm016n8bq7scjlvl2k"))))
+    (build-system meson-build-system)
+    (arguments
+     `( #:meson ,meson-0.55
+        #:build-type "release"))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("wayland-protocols" ,wayland-protocols)
+       ("tllist" ,tllist)
+       ("gcc" ,gcc-10)     ;TODO: Remove when the default compiler is > GCC 7.
+       ("scdoc" ,scdoc)))
+    (inputs
+     `(("wlroots" ,wlroots)
+       ("wayland" ,wayland)
+       ("fcft" ,fcft)
+       ("dbus" ,dbus)
+       ("libpng" ,libpng)))
+    (home-page "https://codeberg.org/dnkl/fnott")
+    (synopsis "Keyboard driven and lightweight Wayland notification daemon")
+    (description "Fnott is a keyboard driven and lightweight notification daemon
+for wlroots-based Wayland compositors.")
+    (license license:expat)))
+
 (define-public awesome
   (package
     (name "awesome")
-- 
2.32.0