diff mbox series

[bug#56128,4/4] gnu: Add gnome-shell-extension-transparent-window

Message ID riL5rUH-N7ksGRJA-coWO6bcYupToYBiCOCX68eJO8RMV-ETxC2BCuVFx4P43QqMooTpBsXs8ohYMKNMJaOMdA7t5cdNlaCYloqgAchFsIM=@proton.me
State Accepted
Headers show
Series [bug#56128] gnu: Add some gnome extensions | expand

Commit Message

Sughosha June 22, 2022, 6:21 a.m. UTC
From 71a7b816831d2491297a5784612767d557fbd114 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 08:09:28 +0200
Subject: [PATCH 4/4] gnu: Add gnome-shell-extension-transparent-window

* gnu/packages/gnome-xyz.scm: Add gnome-shell-extension-transparent-window
---
gnu/packages/gnome-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

--
2.36.1
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0c256c3187..7bf9d433e9 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1072,6 +1072,31 @@  (define-public gnome-shell-extension-sound-output-device-chooser
"This extension shows a list of sound output and input devices (similar to gnome sound settings) in the status menu below the volume slider. Various active ports like HDMI , Speakers etc. of the same device are also displayed for selection.")
(license license:gpl3)))

+(define-public gnome-shell-extension-transparent-window
+ (let ((revision "45") (commit "cc9bc70c192dd565fa6f1d1b28d9a20f99684f2a"))
+ (package
+ (name "gnome-shell-extension-transparent-window")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (commit commit)))
+ (sha256
+ (base32
+ "1f9iqqjpmmylqz0ws8cy5rs475bwzi7jy44q9ip44ig2acz2wxzp"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan `(("."
+ "/share/gnome-shell/extensions/transparent-window@pbxqdown.github.com"))))
+ (home-page
+ "https://github.com/pbxqdown/gnome-shell-extension-transparent-window")
+ (synopsis "Change the opacity of windows in GNOME Shell")
+ (description
+ "The extension will change the opacity of window through simple mouse/keyboard operation.")
+ (license license:expat))))
+
(define-public arc-theme
(package
(name "arc-theme")