diff mbox series

[bug#50170,core-updates-frozen] gnu: mesa: Update to 21.2.1.

Message ID reI0oYP2jCB3nIwqE1ibji2NMv7ycvxFwrWCuveSErrFPlb9b1eGReqvdsZjlYQ6JJq2C42dRT9mJ1T40xhgwkbi-14VOESuil81ZnWhFsM=@protonmail.com
State Accepted
Headers show
Series [bug#50170,core-updates-frozen] gnu: mesa: Update to 21.2.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Oct. 15, 2021, 2:15 a.m. UTC
Hi Maxim!

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Thursday, October 14th, 2021 at 8:42 PM, Maxim Cournoyer wrote:

> Hi!
>
> I wanted to apply this to my batched local core-updates-frozen branch,
> but I get:
>
> error: corrupt patch at line 69
>
> Could you please resend it?
>

Looks like the patch for disabling a test (that fails on i686) needed an update. I've updated the version to 21.2.4 which literally just came out (wow Mesa is fast these days with bugfix versions) and adjusted the patch. I've tested that it applies and builds on x86_64 and with --system=i686-linux successfully.

Let me know if you run into any problem with this version!

John

Comments

Maxim Cournoyer Oct. 15, 2021, 2:27 a.m. UTC | #1
Hello!

John Kehayias <john.kehayias@protonmail.com> writes:

> Hi Maxim!
>
> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
>
> On Thursday, October 14th, 2021 at 8:42 PM, Maxim Cournoyer wrote:
>
>> Hi!
>>
>> I wanted to apply this to my batched local core-updates-frozen branch,
>> but I get:
>>
>> error: corrupt patch at line 69
>>
>> Could you please resend it?
>>
>
> Looks like the patch for disabling a test (that fails on i686) needed
> an update. I've updated the version to 21.2.4 which literally just
> came out (wow Mesa is fast these days with bugfix versions) and
> adjusted the patch. I've tested that it applies and builds on x86_64
> and with --system=i686-linux successfully.
>
> Let me know if you run into any problem with this version!
>
> John

Successfully applied; thanks for the prompt reply!

Maxim
Maxim Cournoyer Nov. 12, 2021, 6:02 a.m. UTC | #2
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello!
>
> John Kehayias <john.kehayias@protonmail.com> writes:
>
>> Hi Maxim!
>>
>> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
>>
>> On Thursday, October 14th, 2021 at 8:42 PM, Maxim Cournoyer wrote:
>>
>>> Hi!
>>>
>>> I wanted to apply this to my batched local core-updates-frozen branch,
>>> but I get:
>>>
>>> error: corrupt patch at line 69
>>>
>>> Could you please resend it?
>>>
>>
>> Looks like the patch for disabling a test (that fails on i686) needed
>> an update. I've updated the version to 21.2.4 which literally just
>> came out (wow Mesa is fast these days with bugfix versions) and
>> adjusted the patch. I've tested that it applies and builds on x86_64
>> and with --system=i686-linux successfully.
>>
>> Let me know if you run into any problem with this version!
>>
>> John

We now have 21.2.4 in core-updates-frozen since commit
3b9b685d051c44206d1b5efce920c85037ec081c.

Thank you!

Closing,

Maxim
diff mbox series

Patch

From a1115434c5f67f2b4c2bfe69c0344416c45971d4 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Thu, 14 Oct 2021 22:12:41 -0400
Subject: [PATCH] * gnu/packages/gl.scm (mesa): Update to 21.2.4.

* gnu/packages/patches/mesa-skip-tests.patch: Adjust for current version.
---
 gnu/packages/gl.scm                        |  4 ++--
 gnu/packages/patches/mesa-skip-tests.patch | 28 +++++++---------------
 2 files changed, 11 insertions(+), 21 deletions(-)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 52b7508d6b..ccb78675f4 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -238,7 +238,7 @@  also known as DXTn or DXTC) for Mesa.")
 (define-public mesa
   (package
     (name "mesa")
-    (version "21.1.6")
+    (version "21.2.4")
     (source
       (origin
         (method url-fetch)
@@ -250,7 +250,7 @@  also known as DXTn or DXTC) for Mesa.")
                                   version "/mesa-" version ".tar.xz")))
         (sha256
          (base32
-          "0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
+          "0i2vz3ppcgqm076546imzl11jr3rlch1iv62lffk60mcs61dwvpy"))
         (patches
          (search-patches "mesa-skip-tests.patch"))))
     (build-system meson-build-system)
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 8f587ea7ef..7ff571dcf5 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -5,25 +5,15 @@  completely with this patch:
 https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
 
 diff --git a/src/util/meson.build b/src/util/meson.build
-index 0893f64..909b3e0 100644
+index 319b22d9bf7..93790c72675 100644
 --- a/src/util/meson.build
 +++ b/src/util/meson.build
-@@ -289,18 +289,6 @@ if with_tests
-      suite : ['util'],
-   )   
+@@ -344,7 +344,7 @@ if with_tests
+     )
+   endif
  
--  test(
--    'u_debug_stack',
--    executable(
--      'u_debug_stack_test',
--      files('u_debug_stack_test.cpp'),
--      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
--      dependencies : [idep_mesautil, idep_gtest],
--      c_args : [c_msvc_compat_args],
--    ),
--     suite : ['util'],
--  )
--
-   process_test_exe = executable(
-     'process_test',
-     files('process_test.c'),
+-  foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
++  foreach t: ['bitset', 'register_allocate', 'u_qsort']
+     test(
+       t,
+       executable(
-- 
2.33.0