diff mbox series

[bug#47722] gnu: python-mechanicalsoup: Update to 1.0.0

Message ID ptMBKfXwfNLNcFIGfDJgxphHqOg4v94QyYnVCsDNClNEGSxdMvPIzRLkStmHc55UUrjJNW4Vsq0lOQuIxDapKBONxHTvDL6lpNhyuhIyMSE=@elenq.tech
State Accepted
Headers show
Series [bug#47722] gnu: python-mechanicalsoup: Update to 1.0.0 | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ekaitz Zarraga April 12, 2021, 10:22 a.m. UTC
From 3fe85d531c56e025868eb90def1b491a9fa32a60 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Mon, 12 Apr 2021 12:15:44 +0200
Subject: [PATCH] gnu: python-mechanicalsoup: Update to 1.0.0

    * gnu/packages/python-web.scm (python-mechanicalsoup): Update to
    1.0.0.
    (python-machanicalsoup): Enable tests
---
 gnu/packages/python-web.scm | 23 +++++++++++------------
 1 file changed, 11 insertions(+), 12 deletions(-)

--
2.31.0

Comments

Efraim Flashner April 12, 2021, 12:17 p.m. UTC | #1
Thanks. I adjusted the indentation and fixed hangups so it doesn't break
with the newer version.

Patch pushed!
M April 12, 2021, 3:04 p.m. UTC | #2
On Mon, 2021-04-12 at 10:22 +0000, Ekaitz Zarraga wrote:
> From 3fe85d531c56e025868eb90def1b491a9fa32a60 Mon Sep 17 00:00:00 2001
> From: Ekaitz Zarraga <ekaitz@elenq.tech>
> Date: Mon, 12 Apr 2021 12:15:44 +0200
> Subject: [PATCH] gnu: python-mechanicalsoup: Update to 1.0.0
> 
>     * gnu/packages/python-web.scm (python-mechanicalsoup): Update to
>     1.0.0.
>     (python-machanicalsoup): Enable tests
Nitpick: a period after ‘Enable tests’.

Unlike in "ChangeLog" files, the changelog entry in commit messages
are not indented.  These tabs can be removed.

> ---
>  gnu/packages/python-web.scm | 23 +++++++++++------------
>  1 file changed, 11 insertions(+), 12 deletions(-)
> 
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index c79fa1bfc4..e842112e97 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -40,6 +40,7 @@
>  ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
>  ;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
>  ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
> +;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -795,29 +796,27 @@ object graph to and from JSON.")
>  (define-public python-mechanicalsoup
>    (package
>      (name "python-mechanicalsoup")
> -    (version "0.11.0")
> +    (version "1.0.0")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (pypi-uri "MechanicalSoup" version))
>         (sha256
> -        (base32 "0k59wwk75q7nz6i6gynvzhagy02ql0bv7py3qqcwgjw7607yq4i7"))))
> +        (base32 "01sddjxy3rznh63hnl5lbv1hhk6xyiviwmkiw4x7v4ap35fb3lrp"))))
>      (build-system python-build-system)
> -    (arguments
> -     ;; TODO: Enable tests when python-flake8@3.5 hits master.
> -     `(#:tests? #f))

Nice!

Warning: I haven't tried to build this.  But from a cursory look, the patch LGTM!
This package has one depending package: hangups@0.4.13.  Does that package still
build?

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c79fa1bfc4..e842112e97 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -795,29 +796,27 @@  object graph to and from JSON.")
 (define-public python-mechanicalsoup
   (package
     (name "python-mechanicalsoup")
-    (version "0.11.0")
+    (version "1.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "MechanicalSoup" version))
        (sha256
-        (base32 "0k59wwk75q7nz6i6gynvzhagy02ql0bv7py3qqcwgjw7607yq4i7"))))
+        (base32 "01sddjxy3rznh63hnl5lbv1hhk6xyiviwmkiw4x7v4ap35fb3lrp"))))
     (build-system python-build-system)
-    (arguments
-     ;; TODO: Enable tests when python-flake8@3.5 hits master.
-     `(#:tests? #f))
     (propagated-inputs
      `(("python-beautifulsoup4" ,python-beautifulsoup4)
        ("python-lxml" ,python-lxml)
        ("python-requests" ,python-requests)
        ("python-six" ,python-six)))
-    ;; (native-inputs
-    ;;  ;; For tests.
-    ;;  `(("python-pytest-flake8" ,python-pytest-flake8)
-    ;;    ("python-pytest-httpbin" ,python-pytest-httpbin)
-    ;;    ("python-pytest-mock" ,python-pytest-mock)
-    ;;    ("python-pytest-runner" ,python-pytest-runner)
-    ;;    ("python-requests-mock" ,python-requests-mock)))
+       (native-inputs
+        ;; For tests.
+        `(("python-pytest-flake8"  ,python-pytest-flake8)
+          ("python-pytest-httpbin" ,python-pytest-httpbin)
+          ("python-pytest-cov"     ,python-pytest-cov)
+          ("python-pytest-mock"    ,python-pytest-mock)
+          ("python-pytest-runner"  ,python-pytest-runner)
+          ("python-requests-mock"  ,python-requests-mock)))
     (home-page "https://mechanicalsoup.readthedocs.io/")
     (synopsis "Python library for automating website interaction")
     (description