diff mbox series

[bug#49339,core-updates] gnu: mesa: Update to 21.1.6.

Message ID porF62NW175MdklHsQWgYkcwmPEyiXyx4f4jWUpWQ6YT-Xqj1_EqC07KEG9du4rghHlYEbdCouQTZPANbS26EXm241x8fC4_mjBEvIHh65A=@protonmail.com
State Accepted
Headers show
Series [bug#49339,core-updates] gnu: mesa: Update to 21.1.6. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias July 29, 2021, 4:52 a.m. UTC
Noticed that Mesa has had a few quick bug fix releases, here is v3 of the patch now to update Mesa to 21.1.6. I've tested that it builds, and since these are bug fix releases there should be no major changes.

Thanks!
John

Comments

Ludovic Courtès July 31, 2021, 10:33 a.m. UTC | #1
Hi John,

John Kehayias <john.kehayias@protonmail.com> skribis:

> gnu: mesa: Update to 21.1.6.
>
> * gnu/packages/gl.scm (mesa): Update to 21.1.6.
> * gnu/packages/patches/mesa-skip-tests.patch: Remove cache_test.c as it is no
> longer needed (test passes).

Applied, thanks!

[...]

> -         "-Dosmesa=gallium"
> +         "-Dosmesa=true"

Is this expected to change anything feature-wise?

BTW, please generate the patch with ‘git format-patch’ next time; that
makes it easier to apply with ‘git am’.

Ludo’.
John Kehayias July 31, 2021, 2:01 p.m. UTC | #2
Hi Ludo’,

On Saturday, July 31st, 2021 at 6:33 AM, Ludovic Courtès <ludo@gnu.org> wrote:

> Hi John,
>
> John Kehayias john.kehayias@protonmail.com skribis:
>
> > gnu: mesa: Update to 21.1.6.
> >
> > -   gnu/packages/gl.scm (mesa): Update to 21.1.6.
> > -   gnu/packages/patches/mesa-skip-tests.patch: Remove cache_test.c as it is no
> >
> >     longer needed (test passes).
>
> Applied, thanks!
>

Great, thank you!

> [...]
>
> > -           "-Dosmesa=gallium"
> >
> >
> >
> > -           "-Dosmesa=true"
> >
> >
>
> Is this expected to change anything feature-wise?
>

Mesa at v21 removed the software OSMesa driver (see https://www.phoronix.com/scan.php?page=news_item&px=Classic-OSMesa-Retires ). We were already using the gallium driver so I think there is no change for us, but the compile flag changed to a boolean: true for what was before gallium, based on my reading of the change https://cgit.freedesktop.org/mesa/mesa/commit/?id=ee802372180a2b4460cc7abb53438e45c6b6f1e4

> BTW, please generate the patch with ‘git format-patch’ next time; that
>
> makes it easier to apply with ‘git am’.
>

Will do, sorry about that (I think I did do that but may have manually altered the header).

By the way, I'm looking now and see mesa-opencl failing, I'll take a look (perhaps an option change or library location?).

John
Ludovic Courtès Aug. 2, 2021, 1:27 p.m. UTC | #3
Hi,

John Kehayias <john.kehayias@protonmail.com> skribis:

> On Saturday, July 31st, 2021 at 6:33 AM, Ludovic Courtès <ludo@gnu.org> wrote:

[...]

>> > -           "-Dosmesa=gallium"
>> >
>> >
>> >
>> > -           "-Dosmesa=true"
>> >
>> >
>>
>> Is this expected to change anything feature-wise?
>>
>
> Mesa at v21 removed the software OSMesa driver (see https://www.phoronix.com/scan.php?page=news_item&px=Classic-OSMesa-Retires ). We were already using the gallium driver so I think there is no change for us, but the compile flag changed to a boolean: true for what was before gallium, based on my reading of the change https://cgit.freedesktop.org/mesa/mesa/commit/?id=ee802372180a2b4460cc7abb53438e45c6b6f1e4

Makes sense, thanks for explaining!

Ludo’.
diff mbox series

Patch

gnu: mesa: Update to 21.1.6.

* gnu/packages/gl.scm (mesa): Update to 21.1.6.
* gnu/packages/patches/mesa-skip-tests.patch: Remove cache_test.c as it is no
longer needed (test passes).
---
 gnu/packages/gl.scm                        | 11 ++++++-----
 gnu/packages/patches/mesa-skip-tests.patch | 20 --------------------
 2 files changed, 6 insertions(+), 25 deletions(-)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index cc5131b28d..d1a8dc0efa 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -237,7 +238,7 @@  also known as DXTn or DXTC) for Mesa.")
 (define-public mesa
   (package
     (name "mesa")
-    (version "20.2.6")
+    (version "21.1.6")
     (source
       (origin
         (method url-fetch)
@@ -249,7 +250,7 @@  also known as DXTn or DXTC) for Mesa.")
                                   version "/mesa-" version ".tar.xz")))
         (sha256
          (base32
-          "1nw5k2qrlcrp5bljy1lmyybgl525y0h44synkbbirw92qv3a6b7i"))
+          "0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
         (patches
          (search-patches "mesa-skip-tests.patch"))))
     (build-system meson-build-system)
@@ -309,7 +310,7 @@  also known as DXTn or DXTC) for Mesa.")
          "-Dglx=dri"        ;Thread Local Storage, improves performance
          ;; "-Dopencl=true"
          ;; "-Domx=true"
-         "-Dosmesa=gallium"
+         "-Dosmesa=true"
          "-Dgallium-xa=enabled"
 
          ;; features required by wayland
@@ -417,8 +418,8 @@  also known as DXTn or DXTC) for Mesa.")
              (let ((out (assoc-ref outputs "out"))
                    (bin (assoc-ref outputs "bin")))
                ;; Not all architectures have the Vulkan overlay control script.
-               (mkdir-p (string-append bin "/bin"))
-               (call-with-output-file (string-append bin "/bin/.empty")
+               (mkdir-p (string-append out "/bin"))
+               (call-with-output-file (string-append out "/bin/.empty")
                  (const #t))
                (copy-recursively (string-append out "/bin")
                                  (string-append bin "/bin"))
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 2622d5d312..8f587ea7ef 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -1,23 +1,3 @@ 
-disk_cache_create() here looks up the users home directory from <pwd.h>
-which resolves to "/" in the build environment. I could not find an easy
-way to set the home directory to something else, so we disable this test
-for now.
-
---- a/src/compiler/glsl/tests/cache_test.c
-+++ b/src/compiler/glsl/tests/cache_test.c
-@@ -170,11 +170,6 @@
-    unsetenv("MESA_GLSL_CACHE_DIR");
-    unsetenv("XDG_CACHE_HOME");
- 
--   cache = disk_cache_create("test", "make_check", 0);
--   expect_non_null(cache, "disk_cache_create with no environment variables");
--
--   disk_cache_destroy(cache);
--
-    /* Test with XDG_CACHE_HOME set */
-    setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
-    cache = disk_cache_create("test", "make_check", 0);
-
 This test fails on i686-linux. I couldn't come up with a regex that
 could be used to disable it just on i686-linux, so we disable it
 completely with this patch:
-- 
2.32.0