diff mbox series

[bug#62282] gnu: gerbil: Upgrade to 0.17.0.

Message ID pNKW-ofctVMCSivZsLfj0vL5GcFzDJc-tOXgxg85Ug4eT7J5qMfVSezsuu_3BKEHl8Kcg8UMCpdq4gROMB7UJbPq866f_wYJ1bE0b0FrX54=@protonmail.com
State New
Headers show
Series [bug#62282] gnu: gerbil: Upgrade to 0.17.0. | expand

Commit Message

J. Sims March 19, 2023, 11:06 p.m. UTC
Hello,

Attached is a patch to upgrade Gerbil to the latest version. In addition, it fixes a few issues:

* switch build code to use g-expressions
* use the `#:tests?' argument of `arguments' instead of deleting the `check' phase
* run `guix style'
* fix issue with missing version file during build

Honestly, I'm not sure I fixed the latter issue in the most idiomatic way. I simply printed the appropriate s-expression to the appropriate file using Guile's `format'. If anyone has advice for a cleaner/more robust way to handle that, please let me know.

Note that I initially tried to fix the version file issue by ignoring the build instructions in the Gerbil guide and instead using the autotools build infrastructure whose artifacts can be seen in the top-level directory of the Gerbil repository. This ran into a different issue, and in the process of diagnosing it, I realized that the build infrastructure in question was written specifically for the previous version. There being no good reason to solve that problem over this one, and realizing that proper versioning would complicate the use of that system even more than solving the missing version file issue, I elected to pursue the route I did.

This is far too much information for a git commit message, but I did feel it worth mentioning somewhere.

Thanks,
Juli

Comments

Bruno Victal March 21, 2023, 1:57 p.m. UTC | #1
Hi Juli,

On 2023-03-19 23:06, J. Sims via Guix-patches via wrote:
> Hello,
> 
> Attached is a patch to upgrade Gerbil to the latest version. In addition, it fixes a few issues:
> 
> * switch build code to use g-expressions
> * use the `#:tests?' argument of `arguments' instead of deleting the `check' phase
> * run `guix style'
> * fix issue with missing version file during build
> 
> Honestly, I'm not sure I fixed the latter issue in the most idiomatic way. I simply printed the appropriate s-expression to the appropriate file using Guile's `format'. If anyone has advice for a cleaner/more robust way to handle that, please let me know.
> 
> Note that I initially tried to fix the version file issue by ignoring the build instructions in the Gerbil guide and instead using the autotools build infrastructure whose artifacts can be seen in the top-level directory of the Gerbil repository. This ran into a different issue, and in the process of diagnosing it, I realized that the build infrastructure in question was written specifically for the previous version. There being no good reason to solve that problem over this one, and realizing that proper versioning would complicate the use of that system even more than solving the missing version file issue, I elected to pursue the route I did.
> 
> This is far too much information for a git commit message, but I did feel it worth mentioning somewhere.

You should split these changes into separate commits.

Take a look at <https://issues.guix.gnu.org/61845> or search the git history for “G-Expression”
for some inspiration in how to split them.


Cheers,
Bruno
diff mbox series

Patch

From 08f88a578060bdd6017f1ab00dea9c882e11f12d Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Sun, 19 Mar 2023 18:27:14 -0400
Subject: [PATCH] gnu: gerbil: Upgrade to 0.17.0.

* gnu/packages/scheme.scm (gerbil): Upgrade to 0.17.0.
---
 gnu/packages/scheme.scm | 177 +++++++++++++++++++++-------------------
 1 file changed, 91 insertions(+), 86 deletions(-)

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index e6a9ef1db0..30550b0d8f 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1113,94 +1113,99 @@  (define-public cl-airship-scheme
 (define-public gerbil
   (package
     (name "gerbil")
-    (version "0.16")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/vyzo/gerbil")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0vng0kxpnwsg8jbjdpyn4sdww36jz7zfpfbzayg9sdpz6bjxjy0f"))))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'bootstrap)
-         (add-before 'configure 'chdir
-           (lambda _
-             (chdir "src")
-             #t))
-         (replace 'configure
-           (lambda* (#:key outputs inputs #:allow-other-keys)
-             (invoke "chmod" "755" "-R" ".")
-             ;; Otherwise fails when editing an r--r--r-- file.
-             (invoke "gsi-script" "configure"
-                     "--prefix" (assoc-ref outputs "out")
-                     "--with-gambit" (assoc-ref inputs "gambit-c"))))
-         (add-before 'patch-generated-file-shebangs 'fix-gxi-shebangs
-           (lambda _
-             ;; Some .ss files refer to gxi using /usr/bin/env gxi
-             ;; and 'patch-generated-file-shebangs can't fix that
-             ;; because gxi has not been compiled yet.
-             ;; We know where gxi is going to end up so we
-             ;; Doctor Who our fix here before the problem
-             ;; happens towards the end of the build.sh script.
-             (let ((abs-srcdir (getcwd)))
-               (for-each
-                (lambda (f)
-                   (substitute* f
-                     (("#!/usr/bin/env gxi")
-                      (string-append "#!" abs-srcdir "/../bin/gxi"))))
-                 '("./gerbil/gxc"
-                   "./lang/build.ss"
-                   "./misc/http-perf/build.ss"
-                   "./misc/rpc-perf/build.ss"
-                   "./misc/scripts/docsnarf.ss"
-                   "./misc/scripts/docstub.ss"
-                   "./misc/scripts/docsyms.ss"
-                   "./r7rs-large/build.ss"
-                   "./release.ss"
-                   "./std/build.ss"
-                   "./std/run-tests.ss"
-                   "./std/web/fastcgi-test.ss"
-                   "./std/web/rack-test.ss"
-                   "./tools/build.ss"
-                   "./tutorial/httpd/build.ss"
-                   "./tutorial/kvstore/build.ss"
-                   "./tutorial/lang/build.ss"
-                   "./tutorial/proxy/build-static.ss"
-                   "./tutorial/proxy/build.ss")))
-             #t))
-         (replace
-          'build
-          (lambda*
-           (#:key inputs #:allow-other-keys)
-           (setenv "HOME" (getcwd))
-             (invoke
-              ;; The build script needs a tty or it'll crash on an ioctl
-              ;; trying to find the width of the terminal it's running on.
-              ;; Calling in script prevents that.
-              "script"
-              "-qefc"
-              "./build.sh")))
-         (delete 'check)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin"))
-                    (lib (string-append out "/lib")))
-               (mkdir-p bin)
-               (mkdir-p lib)
-               (copy-recursively "../bin" bin)
-               (copy-recursively "../lib" lib)))))))
-    (native-inputs
-     (list coreutils util-linux))
-    (propagated-inputs
-     (list gambit-c zlib openssl sqlite))
+    (version "0.17.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/vyzo/gerbil")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0c0nspm659ybgmqlppdv7sxzll4hwkvcp9qmcsip6d0kz0p8r9c3"))))
     (build-system gnu-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (delete 'bootstrap)
+                        (add-before 'configure 'chdir
+                          (lambda _
+                            (chdir "src")))
+                        (replace 'configure
+                          (lambda _
+                            (invoke "chmod" "755" "-R" ".")
+                            ;; Otherwise fails when editing an r--r--r-- file.
+                            (invoke "gsi-script"
+                                    "configure"
+                                    "--prefix"
+                                    #$output
+                                    "--with-gambit"
+                                    #$gambit-c)))
+                        (add-before 'patch-generated-file-shebangs 'fix-gxi-shebangs
+                          (lambda _
+                            ;; Some .ss files refer to gxi using /usr/bin/env gxi
+                            ;; and 'patch-generated-file-shebangs can't fix that
+                            ;; because gxi has not been compiled yet.
+                            ;; We know where gxi is going to end up so we
+                            ;; Doctor Who our fix here before the problem
+                            ;; happens towards the end of the build.sh script.
+                            (let ((abs-srcdir (getcwd)))
+                              (for-each (lambda (f)
+                                          (substitute* f
+                                            (("#!/usr/bin/env gxi")
+                                             (string-append "#!" abs-srcdir
+                                                            "/../bin/gxi"))))
+                                        '("./gerbil/gxc" "./lang/build.ss"
+                                          "./misc/http-perf/build.ss"
+                                          "./misc/rpc-perf/build.ss"
+                                          "./misc/scripts/docsnarf.ss"
+                                          "./misc/scripts/docstub.ss"
+                                          "./misc/scripts/docsyms.ss"
+                                          "./r7rs-large/build.ss"
+                                          "./release.ss"
+                                          "./std/build.ss"
+                                          "./std/run-tests.ss"
+                                          "./std/web/fastcgi-test.ss"
+                                          "./std/web/rack-test.ss"
+                                          "./tools/build.ss"
+                                          "./tutorial/httpd/build.ss"
+                                          "./tutorial/kvstore/build.ss"
+                                          "./tutorial/lang/build.ss"
+                                          "./tutorial/proxy/build-static.ss"
+                                          "./tutorial/proxy/build.ss")))))
+                        (add-after 'configure 'create-gx-version.scm
+                          (lambda _
+                            (call-with-output-file (format #f
+                                                    "~a/gerbil/runtime/gx-version.scm"
+                                                    (getcwd))
+                              (lambda (p)
+                                (format p
+                                 "(define (gerbil-version-string) \"v~s\")"
+                                 #$(version-major+minor version))))))
+                        (replace 'build
+                          (lambda _
+                            (setenv "HOME"
+                                    (getcwd))
+                            (invoke
+                             ;; The build script needs a tty or it'll crash on an ioctl
+                             ;; trying to find the width of the terminal it's running on.
+                             ;; Calling in script prevents that.
+                             "script"
+                             "-qefc"
+                             "./build.sh")))
+                        (replace 'install
+                          (lambda _
+                            (let* ((bin (string-append #$output "/bin"))
+                                   (lib (string-append #$output "/lib")))
+                              (mkdir-p bin)
+                              (mkdir-p lib)
+                              (copy-recursively "../bin" bin)
+                              (copy-recursively "../lib" lib)))))
+           #:tests? #f))
+    (native-inputs (list coreutils gambit-c util-linux))
+    (propagated-inputs (list gambit-c zlib openssl sqlite))
     (synopsis "Meta-dialect of Scheme with post-modern features")
-    (description "Gerbil is an opinionated dialect of Scheme designed for Systems
+    (description
+     "Gerbil is an opinionated dialect of Scheme designed for Systems
 Programming, with a state of the art macro and module system on top of the Gambit
 runtime.  The macro system is based on quote-syntax, and provides the full meta-syntactic
 tower with a native implementation of syntax-case.  It also provides a full-blown module

base-commit: 80d31a7478fa736802c106765662e0b33e2f472e
-- 
2.39.2