diff mbox series

[bug#56140,Patches] Add and update music packages

Message ID o8Acm5cfOaqtnIzq2115gx9xgJ2jE0FcDoyhmSHDnUyYRqrMF8zeNDErpYpVcjmuokpGtGw__RkbqGW5xetv_xl_kkmC88mofx2bh08OU4Q=@proton.me
State New
Headers show
Series [bug#56140,Patches] Add and update music packages | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sughosha June 22, 2022, 12:36 p.m. UTC
Empty Message

Comments

Alice BRENON June 28, 2022, 7:45 a.m. UTC | #1
Hi !

Thanks for submitting this patch ! I'm in no position to provide
a definitive answer to accept or reject this but here are some immediate
things that could be improved.

- your description of Fabla doesn't add much information compared to
  the synopsis. What makes it special ? How is it different from the
  other similar tools ? (see
  https://guix.gnu.org/fr/manual/devel/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions
  for inspiration)
- the other packages seem to have more extensive description, but they
  make very long lines, have you tried formatting your package using
  the `guix style` command ?
  (https://guix.gnu.org/fr/manual/devel/en/html_node/Formatting-Code.html#Formatting-Code)
- you seem to consistently use the "old" syntax for
  packages in native-inputs, as opposed to inputs, is there a good
  reason for that or have you maybe only found examples where the
  native-inputs haven't been modernized ? While it makes sense to
  rename `cmake-minimal` to `cmake` in the definition of
  `distrho-ports` (though I wonder `luppp` didn't require the same
  renaming and keeps the key "cmake-minimal" for `cmake-minimal`, all
  the others occurrences (`("pkg-config" ,pkg-config)`, `("lv2" ,lv2)`…)
  are totally unneeded for as far as I understand and could be
  simplified as `(list pkg-config lv2 mesa)`.

I'm also a bit curious as to why tests need to be explicitly
deactivated in `sorcer`, does running the default cmake command to test
the project result in a failure, not just a NOP ?

I hope some other people will take it over from there because I don't
have much more to contribute : )

Cheers,

Alice
Sughosha June 28, 2022, 8:30 a.m. UTC | #2
Hi Alice,

First of all, thanks for reviewing my patches :)
> - your description of Fabla doesn't add much information compared to the synopsis. What makes it special ? How is it different from the other similar tools ? (see https://guix.gnu.org/fr/manual/devel/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions for inspiration)
I will improve the descriptions.
> - the other packages seem to have more extensive description, but they make very long lines, have you tried formatting your package using the `guix style` command ? (https://guix.gnu.org/fr/manual/devel/en/html_node/Formatting-Code.html#Formatting-Code)
Sorry that I have forgot this step. I will do it.
> - you seem to consistently use the "old" syntax for packages in native-inputs, as opposed to inputs, is there a good reason for that or have you maybe only found examples where the native-inputs haven't been modernized ? While it makes sense to rename `cmake-minimal` to `cmake` in the definition of `distrho-ports` (though I wonder `luppp` didn't require the same renaming and keeps the key "cmake-minimal" for `cmake-minimal`, all the others occurrences (`("pkg-config" ,pkg config)`, `("lv2" ,lv2)`…) are totally unneeded for as far as I understand and could be simplified as `(list pkg-config lv2 mesa)`.
It's just that I practiced to use the old way for native-inputs. Many packages require to do so, for example `("glib:bin" ,glib "bin")` cannot be declared as somethig like `(list glib)` (as far as I know). It's just that mejority of the packages I defined had required such type of native-inputs, so I practiced it that way.
> I'm also a bit curious as to why tests need to be explicitly deactivated in `sorcer`, does running the default cmake command to test the project result in a failure, not just a NOP ?
`sorcer` was initially not packaged by me. It was failing to build, so I updated it to the most recent commit and removed the commands in the arguments which are no longer required in this commit. Disabling the tests is as it was before, as in the comment it says that tests are not defined in the git repository.

I will improve the patches, fixing mistakes, and then resend the patches.
Thank you.
M June 28, 2022, 12:40 p.m. UTC | #3
Sughosha via Guix-patches via schreef op di 28-06-2022 om 08:30
[+0000]:
> glib:bin" ,glib "bin")` cannot be declared as somethig like `(list
> glib)` (as far as I know). 

You can do (list `(,glib "bin") hello other-package etc...) (untested).

Greetings,
Maxime.
Ricardo Wurmus Sept. 2, 2023, 8:40 a.m. UTC | #4
Hi Sughosha,

I’ve applied the latest version of your patches with a few minor
changes:

- some indentation changes
- changed the build phase to do without for-each.

Thank you for your patience!
diff mbox series

Patch

From e695d37744c81963f22e93af9aafbadd38983b5a Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Wed, 22 Jun 2022 14:32:11 +0200
Subject: [PATCH 3/4] gnu: Add luppp

* gnu/packages/music.scm: add luppp
---
 gnu/packages/music.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e691d43d12..a3710adf3a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5054,6 +5054,33 @@  (define-public patchmatrix
 OSC connections.")
     (license license:artistic2.0)))
 
+(define-public luppp
+  (let ((revision "29") (commit "23da1497f80dbace48b7807afd3570c57a4d5994"))
+    (package
+      (name "luppp")
+      (version (git-version "1.2.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/openAVproductions/openAV-Luppp")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1rjl7fwnqq1gxa3haw1z0p1mld23i194sc43m03h9isagkwxrx9d"))))
+      (build-system meson-build-system)
+      (native-inputs `(("pkg-config" ,pkg-config) ("cmake-minimal" ,cmake-minimal)))
+      (inputs (list cairo
+                    ntk
+                    liblo
+                    jack-1
+                    libsndfile
+                    libsamplerate))
+      (home-page "http://openavproductions.com/luppp")
+      (synopsis "Live performance tool")
+      (description
+       "Luppp is a music creation tool, intended for live use. The focus is on real time processing and a fast and intuitive workflow with MIDI mapping support.")
+      (license license:gpl3))))
+
 (define-public sorcer
   (let ((revision "6") (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
     (package
-- 
2.36.1