diff mbox series

[bug#52530,core-updates-frozen] WIP: Add rust-gtk4 and dependencies

Message ID nz6ufi3kyaiitn6sxt3tiygoqpceh2jck7ol2jcs4yyed4swhm@apqt543jn75k
State New
Headers show
Series [bug#52530,core-updates-frozen] WIP: Add rust-gtk4 and dependencies | expand

Commit Message

Herman Rimm Jan. 25, 2024, 5:47 p.m. UTC
Hi Maxim,

Apologies, it seems rust-gtk4-rs and dependency packages were also
written by Sergio Pastor Pérez and merged into rust-team. Aside from the
descriptions and comments, the diff is:


You can close this thread (or could I?).

Cheers,
Herman

Comments

Maxim Cournoyer Jan. 27, 2024, 3:15 a.m. UTC | #1
Hi Herman,

Herman Rimm <herman@rimm.ee> writes:

> Hi Maxim,
>
> Apologies, it seems rust-gtk4-rs and dependency packages were also
> written by Sergio Pastor Pérez and merged into rust-team. Aside from the
> descriptions and comments, the diff is:
>
> diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
> index 51f02788d3..6d419c0318 100644
> --- a/gnu/packages/crates-gtk.scm
> +++ b/gnu/packages/crates-gtk.scm
> @@ -2660,14 +2660,13 @@ (define-public rust-gtk4-macros-0.7
>                         ("rust-proc-macro2" ,rust-proc-macro2-1)
>                         ("rust-quick-xml" ,rust-quick-xml-0.30)
>                         ("rust-quote" ,rust-quote-1)
> -                       ("rust-gtk4" ,rust-gtk4-0.7)
>                         ("rust-syn" ,rust-syn-1))
>         #:cargo-development-inputs (("rust-futures-channel" ,rust-futures-channel-0.3)
>                                     ("rust-futures-util" ,rust-futures-util-0.3)
>                                     ("rust-gtk4" ,rust-gtk4-0.7)
>                                     ("rust-trybuild2" ,rust-trybuild2-1))))
>      (native-inputs (list pkg-config))
> -    (inputs (list gdk-pixbuf gtk))
> +    (inputs (list gtk))
>      (home-page "https://gtk-rs.org/")
>      (synopsis "Macros helpers for GTK 4 bindings")
>      (description "Macros helpers for GTK 4 bindings.")
>
> You can close this thread (or could I?).

Thanks for the heads-up.  I'm closing this thread by replying to
52530-done@debbugs.gnu.org in CC.
diff mbox series

Patch

diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 51f02788d3..6d419c0318 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -2660,14 +2660,13 @@  (define-public rust-gtk4-macros-0.7
                        ("rust-proc-macro2" ,rust-proc-macro2-1)
                        ("rust-quick-xml" ,rust-quick-xml-0.30)
                        ("rust-quote" ,rust-quote-1)
-                       ("rust-gtk4" ,rust-gtk4-0.7)
                        ("rust-syn" ,rust-syn-1))
        #:cargo-development-inputs (("rust-futures-channel" ,rust-futures-channel-0.3)
                                    ("rust-futures-util" ,rust-futures-util-0.3)
                                    ("rust-gtk4" ,rust-gtk4-0.7)
                                    ("rust-trybuild2" ,rust-trybuild2-1))))
     (native-inputs (list pkg-config))
-    (inputs (list gdk-pixbuf gtk))
+    (inputs (list gtk))
     (home-page "https://gtk-rs.org/")
     (synopsis "Macros helpers for GTK 4 bindings")
     (description "Macros helpers for GTK 4 bindings.")