diff mbox series

[bug#53169,1/8] gnu: Add rust-svgtypes-0.5.

Message ID nxKweERKEDux_F0JgEs9dZcK6uWIoYpHSMuEa-t49guz7UX9F2FUQvAOnG_hHiS4k5aW2PFvvsqobBXGFSzTV_2VG-smfL3foXwhKvfJBr4=@protonmail.com
State Accepted
Headers show
Series [bug#53169,1/8] gnu: Add rust-svgtypes-0.5. | expand

Commit Message

phodina Jan. 11, 2022, 12:31 a.m. UTC
Hi,

this patch set updates and adds additional Lyon crates.

----
Petr

Comments

Nicolas Goaziou Jan. 21, 2022, 12:21 a.m. UTC | #1
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> this patch set updates and adds additional Lyon crates.

Thank you.

Note that some of your commit messages were misleading. E.g., when you
write "gnu: rust-euclid-0.22: Update to 0.22.6.", you actually create
a new variable `rust-euclid-0.22' and remove `rust-euclid-0.20'. As
a consequence it broke old revisions of `plotters' and `font-kit'
crates, which I had to remove.

Also, indentation from imported packages is a bit off. You may want to
re-indent packages.

In any case, all applied!

Regards,
phodina Jan. 21, 2022, 5:08 a.m. UTC | #2
Hi Nicolas,

> Note that some of your commit messages were misleading. E.g., when you
>
> write "gnu: rust-euclid-0.22: Update to 0.22.6.", you actually create
>
> a new variable `rust-euclid-0.22' and remove` rust-euclid-0.20'. As
>
> a consequence it broke old revisions of `plotters' and` font-kit'
>
> crates, which I had to remove.
>
> Also, indentation from imported packages is a bit off. You may want to
>
> re-indent packages.
>
> In any case, all applied!

Thanks for the note. You're right that in case "gnu: rust-euclid-0.22" it's new variable as there are dependencies on the old one.

I'll keep that in mind next time :-)


----
Petr
diff mbox series

Patch

From 00d64f67ff5a3e507f3f18c2e465134d0ebccb52 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Tue, 11 Jan 2022 00:51:22 +0100
Subject: [PATCH 1/8] gnu: Add rust-svgtypes-0.5.

* gnu/packages/crates-io.scm (rust-svgtypes-0.5): New variable.

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 15e67d5561..5f019e8192 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65587,6 +65587,29 @@  (define-public rust-svd-parser-0.9
       "This package provides a CMSIS-SVD file parser")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-svgtypes-0.5
+  (package
+    (name "rust-svgtypes")
+    (version "0.5.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "svgtypes" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "1zv0yb4nfyz78y8k7fmyjqgdh9vf7xc44c9pzry8640szym6ylww"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-float-cmp" ,rust-float-cmp-0.5)
+         ("rust-siphasher" ,rust-siphasher-0.2))))
+    (home-page "https://github.com/RazrFalcon/svgtypes")
+    (synopsis "SVG types parser")
+    (description "This package provides SVG types parser.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-sxd-document-0.3
   (package
     (name "rust-sxd-document")
-- 
2.34.0