From 332ea52f1f060a4fa1b8af7100b4cbd2f481f24b Mon Sep 17 00:00:00 2001
From: Luis Felipe <luis.felipe.la@protonmail.com>
Date: Wed, 28 Dec 2022 12:45:32 -0500
Subject: [PATCH] gnu: Add guile-proba.
* gnu/packages/check.scm (guile-proba): New variable.
---
gnu/packages/check.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)
@@ -41,6 +41,7 @@
;;; Copyright © 2022 David Elsing <david.elsing@posteo.net>
;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -70,6 +71,8 @@ (define-module (gnu packages check)
#:use-module (gnu packages gnome)
#:use-module (gnu packages golang)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages guile)
+ #:use-module (gnu packages guile-xyz)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -78,6 +81,7 @@ (define-module (gnu packages check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages python-science)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages time)
#:use-module (gnu packages xml)
#:use-module (guix utils)
@@ -90,6 +94,7 @@ (define-module (gnu packages check)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
+ #:use-module (guix build-system guile)
#:use-module (guix build-system meson)
#:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
@@ -3455,3 +3460,49 @@ (define-public python-pytest-regressions
tables by saving expected data in a data directory (courtesy of pytest-datadir)
that can be used to verify that future runs produce the same data.")
(license license:expat)))
+
+(define-public guile-proba
+ (package
+ (name "guile-proba")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/luis-felipe/guile-proba")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04si01wzhc9c8rqy9vr12fpkf8gnlx7crkph8djy80s2c7b1lvr7"))))
+ (build-system guile-build-system)
+ (native-inputs (list guile-3.0 texinfo))
+ (propagated-inputs (list guile-3.0 guile-config guile-lib texinfo))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'check
+ (lambda _
+ (invoke "guile" "proba.scm" "run" "tests")))
+ (add-after 'install 'install-script-and-manual
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin-dir (string-append out "/bin"))
+ (info-dir (string-append out "/share/info"))
+ (script (string-append bin-dir "/proba")))
+ (mkdir-p bin-dir)
+ (mkdir-p info-dir)
+ (copy-file "proba.scm" script)
+ (chmod script #o555)
+ (invoke "makeinfo" "manual/main.texi")
+ (install-file "guile-proba" info-dir)))))
+ #:not-compiled-file-regexp
+ "((packages|tests)\\/.*.scm|(proba|manifest).scm)$"))
+ (home-page "https://luis-felipe.gitlab.io/guile-proba/")
+ (synopsis "Testing tools for GNU Guile projects with SRFI 64 test suites")
+ (description
+ "This software is a set of testing tools for GNU Guile projects
+with SRFI 64-based test suites. It comes with a command-line interface
+to run test collections, and a library that includes a test runner and
+helpers for writing tests.")
+ (license license:public-domain)))
base-commit: fc5dc3e04789a15d80a7b35987adaefc1a94b97c
--
2.38.1