diff mbox series

[bug#39628] gnu: accountsservice: 'Add patch-/bin/cat' phase.

Message ID nImNaykxB5G066ZbkFjY_GdiilBPYfvktuHMQK96LNXyjNasMe6T5eY7P7CbVrzJ6GE6CdJAxePvohC4jrldDUWegLpmtW-dRamx2S7nnAI=@protonmail.com
State Accepted
Headers show
Series [bug#39628] gnu: accountsservice: 'Add patch-/bin/cat' phase. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

ashish.is--- via Guix-patches" via Feb. 16, 2020, 1:10 a.m. UTC
Hello,

this patch fix the absolute path for /bin/cat and is required to set thumbnail image for user in GNOME desktop.

Debug error:

--
1) gnome-control-center -v
2) try changing the user's thumbnail.

00:25:56.0336           AccountsService:  WARNING: SetIconFile call failed: GDBus.Error:org.freedesktop.Accounts.Error.Failed: reading file '/gnu/store/k159736sj00s0jkirkr2270nlx6sx6h2-gnome-control-center-3.32.2/share/pixmaps/faces/mountain.jpg' failed: Failed to execute child process “/bin/cat” (No such file or directory)
--

Thanks
Rene

Comments

Marius Bakke Feb. 16, 2020, 3:32 p.m. UTC | #1
Rene via Guix-patches via <guix-patches@gnu.org> writes:

> Hello,
>
> this patch fix the absolute path for /bin/cat and is required to set thumbnail image for user in GNOME desktop.

Good catch, applied in c9aadd074961b149870cbe6128d77b6cacb1d2b6.

By the way, there are some other hard coded file names in that file, for
/usr/bin/passwd and /usr/bin/chage.  We should probably patch those too.

Thanks!
diff mbox series

Patch

From 9df62bc0f1a4e99311191ae940e85b559887a480 Mon Sep 17 00:00:00 2001
From: Rene Saavedra <pacoon@protonmail.com>
Date: Sat, 15 Feb 2020 18:46:14 -0600
Subject: [PATCH] gnu: accountsservice: 'Add patch-/bin/cat' phase.

* gnu/packages/freedesktop.scm (accountsservice)[arguments]: Add 'patch-/bin/cat'
phase.
---
 gnu/packages/freedesktop.scm | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 01466b8ec5..80e185c8e7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
 ;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Rene Saavedra <pacoon@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -921,6 +922,11 @@  message bus.")
          "--enable-elogind")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-/bin/cat
+           (lambda _
+             (substitute* "src/user.c"
+               (("/bin/cat") (which "cat")))
+             #t))
          (add-before
           'configure 'pre-configure
           (lambda* (#:key inputs #:allow-other-keys)
-- 
2.21.0