diff mbox series

[bug#45108] Added emacs-burly

Message ID nCN82e_FRUxyoeHVqEwJ7AEDrg5SaTbVMJ6fDa-QVkadSuv3jRFTSJ9dKP4shhbHS7ACcyZ78Tj5eDJPPOblZjoSihDdNemyXuRuRbvTqZU=@protonmail.com
State Accepted
Headers show
Series [bug#45108] Added emacs-burly | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

rdes Dec. 7, 2020, 11:31 p.m. UTC
Hello,

The attached patches are to add emacs-burly. I've also attached a patch for emacs-map since it's required and not packaged yet. Please let me know in the future if this should be multiple emails.

Ryan

Sent with [ProtonMail](https://protonmail.com) Secure Email.

Comments

Oleg Pykhalov Dec. 8, 2020, 5:01 a.m. UTC | #1
Hello,

Thank you for patches.

rdes via Guix-patches via <guix-patches@gnu.org> writes:

[…]

> Please let me know in the future if this should be multiple emails.

It's a good practice to split an email with multiple patches, which is
described on webpage “Sending a Patch Series” [1].

[1] https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html

> Sent with [ProtonMail](https://protonmail.com) Secure Email.
> From 0e24818db4f22cff0d841b7b77866121e0f2d6a5 Mon Sep 17 00:00:00 2001
> From: Ryan Desfosses <rdes@protonmail.com>
> Date: Mon, 7 Dec 2020 18:17:52 -0500
> Subject: [PATCH 1/2] gnu: Add emacs-map
                                         ^
                                         missing dot

[…]

> +    (synopsis "Map manipulation functions")
> +    (description
> +     "map.el provides map-manipulation functions that work on alists,
> +hash-table and arrays.  All functions are prefixed with \"map-\".")

1. “description should start with an upper-case letter or digit” as
reported by "./pre-inst-env guix lint".

2. Istead of ‘\"map-\"’, please use ‘@code{map-}’.

[…]

> Subject: [PATCH 2/2] gnu: Add emacs-burly
                                           ^
                                           missing dot

Pushed with changes above to master.

Oleg.
Nicolas Goaziou Dec. 8, 2020, 7:23 a.m. UTC | #2
Hello,

Oleg Pykhalov <go.wigust@gmail.com> writes:

> Pushed with changes above to master.

I don't think the emacs-map package is needed as a propagated inputs
since it ships with Emacs. Have you tried building emacs-burly without
it?

For the same reason I'm not even sure we need to provide emacs-map at
all (we do not provide emacs-seq either).

WDYT?

Regards,
Oleg Pykhalov Dec. 8, 2020, 8:59 a.m. UTC | #3
Hello,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> I don't think the emacs-map package is needed as a propagated inputs
> since it ships with Emacs. Have you tried building emacs-burly without
> it?

No, I didn't try.


burly requires map 2.1, but Emacs provides 2.0 (M-x find-library map):
--8<---------------cut here---------------start------------->8---
;; Package-Requires: ((emacs "26.3") (map "2.1"))
--8<---------------cut here---------------end--------------->8---

I don't mind removing map from propagated inputs if it not break burly,
but I'm not a user of this package to decide ;-)


Oleg.
Michael Rohleder Dec. 8, 2020, 8:43 p.m. UTC | #4
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
> Oleg Pykhalov <go.wigust@gmail.com> writes:
>
>> Pushed with changes above to master.
>
> I don't think the emacs-map package is needed as a propagated inputs
> since it ships with Emacs. Have you tried building emacs-burly without
> it?
>
> For the same reason I'm not even sure we need to provide emacs-map at
> all (we do not provide emacs-seq either).
>
> WDYT?

I think, emacs-seq has shown that packages "extracted" from emacs (here:
map, xref, project) can be problematic if they become older than the one
that ship with emacs (and are deeper in the graph?).  Not sure, maybe
this is already an issue for emacs-next users?!
diff mbox series

Patch

From fe69c97b2e228571a58fe87aec453ace52c70748 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <rdes@protonmail.com>
Date: Mon, 7 Dec 2020 18:26:46 -0500
Subject: [PATCH 2/2] gnu: Add emacs-burly

* gnu/packages/emacs-xyz.scm (emacs-burly): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 77d314e5f3..e207dfcbe3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25749,3 +25749,30 @@  s-expression.")
      "map.el provides map-manipulation functions that work on alists,
 hash-table and arrays.  All functions are prefixed with \"map-\".")
     (license license:gpl3+)))
+
+(define-public emacs-burly
+  (package
+    (name "emacs-burly")
+    (version "0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/alphapapa/burly.el")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vaikknjzmhpszyi4yxjjkp1ihgmhpbnbx1s5pjy4mnhl1ibi33b"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("emacs-map" ,emacs-map)))
+    (home-page
+     "https://github.com/alphapapa/burly.el")
+    (synopsis
+     "Save and restore frame/window configurations with buffers")
+    (description
+     "This package provides tools to save and restore frame and window
+configurations in Emacs, including buffers that may not be live
+anymore.  In this way, it's like a lightweight \"workspace\" manager,
+allowing you to easily restore one or more frames, including their
+windows, the windows' layout, and their buffers.")
+    (license license:gpl3+)))
-- 
2.29.2