diff mbox series

[bug#45754] gnu: Add emacs-anki-editor

Message ID mkg7eWRpOP3D810OYfr4Lk8aTVeWB6vcJRUUlIF9yEa8TqRjquYuiOVvZwqYOv6wxJAamc-2A0ee3CZjI018_n8ihBR1PB7FAe-3WCweaoI=@protonmail.com
State Accepted
Headers show
Series [bug#45754] gnu: Add emacs-anki-editor | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Noah Evans Jan. 10, 2021, 6:07 a.m. UTC
---
gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

--
2.30.0

Comments

Nicolas Goaziou Jan. 10, 2021, 6:53 p.m. UTC | #1
Hello,

Noah Evans via Guix-patches via <guix-patches@gnu.org> writes:

> +(define-public emacs-anki-editor

Thank you. Some comments follow.

You did not provide a commit message. Could you provide one? For
example,

    gnu: Add emacs-anki-editor

    * gnu/packages/emacs-xyz.scm (emacs-anki-editor): New variable.

is enough.

Also, your indentation is off. Could you use, e.g., M-q in Emacs to fix
it?

> + (let ((commit "546774a453ef4617b1bcb0d1626e415c67cc88df")
> + (revision "0")
> + (version "0.3.3"))

Could you explain why you chose the latest commit instead "0.3.3"
release? It might be because that release is more than two years old.

> + (package
> + (name "emacs-anki-editor")
> + (version (git-version version revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/louietan/anki-editor")
> + (commit commit)))

There's a

  (file-name (git-file-name name version))

missing here.

> + (sha256
> + (base32
> + "1if610hq5j8rbjh1caw5bwbgnsn231awwxqbpwvrh966kdxzl4qf"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-request" ,emacs-request)
> + ("emacs-dash" ,emacs-dash)))

Could you order inputs alphabetically?

> + (synopsis
> + "Minor mode for making Anki cards with org-mode")

Could you replace org-mode with Org mode?

> + (description
> + "This package is for people who use Anki as SRS but would like to
> +make cards in @code{org-mode}.")

Could you explain in the description what is a "SRS"? Also,
@code{org-mode} should become Org mode.

You can also update your copyright line at the beginning of the file.

As the last point, could you move the package elsewhere than at the end
of the file. There, it is likely to introduce a merge conflict, e.g., if
someone also submits a package there while yours is being reviewed.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c86452fe2b..f1fabd4f17 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26423,3 +26423,32 @@  to pastebin-like services. It supports more than one service and will
failover if one service fails. More services can easily be added over time
and prefered services can easily be configured.")
(license license:gpl3+)))
+
+(define-public emacs-anki-editor
+ (let ((commit "546774a453ef4617b1bcb0d1626e415c67cc88df")
+ (revision "0")
+ (version "0.3.3"))
+ (package
+ (name "emacs-anki-editor")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/louietan/anki-editor")
+ (commit commit)))
+ (sha256
+ (base32
+ "1if610hq5j8rbjh1caw5bwbgnsn231awwxqbpwvrh966kdxzl4qf"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-request" ,emacs-request)
+ ("emacs-dash" ,emacs-dash)))
+ (home-page
+ "https://github.com/louietan/anki-editor")
+ (synopsis
+ "Minor mode for making Anki cards with org-mode")
+ (description
+ "This package is for people who use Anki as SRS but would like to
+make cards in @code{org-mode}.")
+ (license license:gpl3+))))