diff mbox series

[bug#52803] gnu: Add headsetcontrol.

Message ID mE2m1wq0LOmOGyU2iOSj_ylyFw8fo7yU49_zkxwdGIMDntUp4EY_Y6EGZDF6ta8XPG8QEQBXf7i_zW8KkfNjDWvUrIbMsyK2Qx_eoxUrakE=@protonmail.com
State Accepted
Headers show
Series [bug#52803] gnu: Add headsetcontrol. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Dec. 26, 2021, 4:16 p.m. UTC
Attached is a patch to add the program headsetcontrol, which allows getting/setting properties for USB headsets. I've been using a previous version (2.4) locally for quite some time and it works well.

The package also builds udev rules, should a note be added to the description that it includes udev rules or anything about that?

Thanks!

John
diff mbox series

Patch

From 1a22f60566e10b3ce391aa95f3b8b520556cb590 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sun, 26 Dec 2021 11:13:29 -0500
Subject: [PATCH] gnu: Add headsetcontrol.

* gnu/packages/hardware.scm (headsetcontrol): New variable.
---
 gnu/packages/hardware.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index ddd0f5acc1..129ea7c20e 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -316,6 +316,30 @@  (define-public h-client
       (home-page "https://savannah.nongnu.org/projects/h-client/")
       (license license:gpl3+))))
 
+(define-public headsetcontrol
+  (package
+    (name "headsetcontrol")
+    (version "2.6")
+    (source (origin
+             (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/Sapd/HeadsetControl")
+                   (commit version)))
+             (file-name (git-file-name name version))
+             (sha256
+              (base32
+               "0a7zimzi71416pmn6z0l1dn1c2x8p702hkd0k6da9rsznff85a88"))))
+    (build-system cmake-build-system)
+    (inputs
+      (list hidapi))
+    (synopsis "Sidetone and Battery status for USB headsets")
+    (description
+      "A tool to control certain aspects of USB-connected headsets on Linux.
+Currently, support is provided for adjusting sidetone, getting battery state,
+controlling LEDs, and setting the inactive time.")
+    (home-page "https://github.com/Sapd/HeadsetControl")
+    (license license:gpl3)))
+
 (define-public i7z
   (let ((revision "0")
         (commit "1a41ff13db747e962456ddbb5ccb2b7fc43ca0cb"))
-- 
2.34.1