diff mbox series

[bug#43449] gnu: Add python-requests-ftp.

Message ID m1o8m4yib6.fsf@khs-macbook.home
State Accepted
Headers show
Series [bug#43449] gnu: Add python-requests-ftp. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Konrad Hinsen Sept. 17, 2020, 7:27 a.m. UTC
* gnu/packages/python-web.scm (python-requests-ftp): New variable.
---
 gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Leo Famulari Sept. 17, 2020, 5:28 p.m. UTC | #1
On Thu, Sep 17, 2020 at 09:27:09AM +0200, Konrad Hinsen wrote:
> * gnu/packages/python-web.scm (python-requests-ftp): New variable.

Thanks! Pushed as a96873565da1e9a7ef95ab06a5774b1207b86ead with a
followup commit to credit you as an author.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7926539233..6bd413efca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2029,6 +2029,28 @@  with python-requests.")
      `(;; FIXME: Some tests require network access.
        #:tests? #f))))
 
+(define-public python-requests-ftp
+  (package
+    (name "python-requests-ftp")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "requests-ftp" version))
+       (sha256
+        (base32
+         "0yh5v21v36dsjsgv4y9dx4mmz35741l5jf6pbq9w19d8rfsww13m"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-requests" ,python-requests)))
+    (home-page
+     "https://github.com/Lukasa/requests-ftp")
+    (synopsis "FTP Transport Adapter for Requests")
+    (description
+     "Requests-FTP is an implementation of a simple FTP transport
+adapter for use with the Requests library.")
+    (license license:asl2.0)))
+
 (define-public python-oauthlib
   (package
     (name "python-oauthlib")