diff mbox series

[bug#57415,2/2] gnu: snakemake-7: Convert dependencies to propagated-inputs

Message ID m1h720f9dn.fsf@fastmail.net
State Accepted
Headers show
Series [bug#57414,1/2] gnu: snakemake-6: Convert dependencies to propagated-inputs | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Konrad Hinsen Aug. 25, 2022, 6:47 p.m. UTC
* gnu/packages/python-xyz.scm (snakemake-7): Ensure that
"python -m snakemake" works (because snakemake uses it internally)
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Marius Bakke Aug. 29, 2022, 4:12 p.m. UTC | #1
Konrad Hinsen <konrad.hinsen@fastmail.net> skriver:

> * gnu/packages/python-xyz.scm (snakemake-7): Ensure that
> "python -m snakemake" works (because snakemake uses it internally)

Applied, thanks!

I took the liberty to add the missing [inputs], [arguments], etc fiels
to the commit message of these snakemake patches.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 69e3b42927..31e13ad395 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9803,7 +9803,7 @@  (define-public snakemake-7
                ;; to the Google Storage service.
                (delete-file "tests/test_google_lifesciences.py")
                (invoke "pytest")))))))
-    (inputs
+    (propagated-inputs
      (list python-appdirs
            python-configargparse
            python-connection-pool