diff mbox series

[bug#43444,1/2] gnu: Add python-rnc2rng.

Message ID m1een2yqfp.fsf@khs-macbook.home
State Accepted
Headers show
Series [bug#43444,1/2] gnu: Add python-rnc2rng. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Konrad Hinsen Sept. 16, 2020, 10:19 a.m. UTC
* gnu/packages/python-xyz.scm (python-rnc2rng): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 24fc512178..fd58921953 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22016,3 +22016,31 @@  By default it uses the open Python vulnerability database Safety DB.")
     (synopsis "Python wrapper for pandoc.")
     (description "Thin Python wrapper for pandoc.")
     (license license:expat)))
+
+(define-public python-rnc2rng
+  (package
+    (name "python-rnc2rng")
+    (version "2.6.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "rnc2rng" version))
+       (sha256
+        (base32
+         "1kmp3iwxxyzjsd47j2sprd47ihhkwhb3yydih3af5bbfq0ibh1w8"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-rply" ,python-rply)))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "python" "test.py")
+                      #t)))))
+    (home-page "https://github.com/djc/rnc2rng")
+    (synopsis
+     "RELAX NG Compact to regular syntax conversion library")
+    (description
+     "Converts RELAX NG schemata in Compact syntax (rnc) to
+equivalent schemata in the XML-based default RELAX NG syntax.")
+    (license license:expat)))