diff mbox series

[bug#39550] gnu: Add cl-documentation-utils.

Message ID m1blq6grgp.fsf@khs-macbook.home
State Accepted
Headers show
Series [bug#39550] gnu: Add cl-documentation-utils. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Konrad Hinsen Feb. 10, 2020, 4:30 p.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-documentation-utils,
  cl-documentation-utils, ecl-documentation-utils): New variables.
---
 gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Guillaume Le Vaillant Feb. 11, 2020, 8:38 a.m. UTC | #1
sbcl-documentation-utils and cl-documentation-utils had already
been packaged (commit 8dc5ff8fd0f3d007cb097c4055f73a053dc373c7), so
I didn't push this patch and just added ecl-documentation-utils instead
(commit 281537f47b22de288370a0f843301c399b6378f7).
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5c97f37d48..be1f43c0bc 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10270,3 +10270,37 @@  generation functions from the GSL library.")
 
 (define-public ecl-cl-randist
   (sbcl-package->ecl-package sbcl-cl-randist))
+
+(define-public sbcl-documentation-utils
+  (package
+    (name "sbcl-documentation-utils")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Shinmera/documentation-utils.git")
+             (commit "98630dd5f7e36ae057fa09da3523f42ccb5d1f55")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "098qhkqskmmrh4wix34mawf7p5c87yql28r51r75yjxj577k5idq"))))
+    (build-system asdf-build-system/sbcl)
+    (synopsis "Simple tools for documenting Common Lisp libraries")
+    (description
+     "This is a small library to help with managing the docstrings
+of a Common Lisp library.")
+    (home-page "https://github.com/Shinmera/documentation-utils")
+    (license license:zlib)
+    (inputs
+     `(("trivial-indent" ,sbcl-trivial-indent)))
+    (arguments
+     `(#:asd-system-name "documentation-utils"
+       #:asd-file "documentation-utils.asd"
+       #:tests? #f))))
+
+(define-public cl-documentation-utils
+  (sbcl-package->cl-source-package sbcl-documentation-utils))
+
+(define-public ecl-documentation-utils
+  (sbcl-package->ecl-package sbcl-documentation-utils))