diff mbox series

[bug#38290] gnu: nmoldyn: New source code location.

Message ID m1a78r6k8w.fsf@khs-macbook.home
State Accepted
Headers show
Series [bug#38290] gnu: nmoldyn: New source code location. | expand

Commit Message

Konrad Hinsen Nov. 19, 2019, 6:49 p.m. UTC
* gnu/packages/chemistry.scm (nmoldyn): New source code location.
Following the annoucement of Bitbucket to delete all
Mercurial repositories in June 2020, the source code has
been migrated to GitHub.
---
 gnu/packages/chemistry.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès Nov. 21, 2019, 9:11 a.m. UTC | #1
Hello!

Konrad Hinsen <konrad.hinsen@fastmail.net> skribis:

> * gnu/packages/chemistry.scm (nmoldyn): New source code location.
> Following the annoucement of Bitbucket to delete all
> Mercurial repositories in June 2020, the source code has
> been migrated to GitHub.

[...]

> -       (method url-fetch)
> -       (uri (string-append "https://bitbucket.org/khinsen/"
> -                           "nmoldyn3/downloads/nMOLDYN-"
> -                           version ".tar.gz"))
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/khinsen/nMOLDYN3")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
>         (sha256
>          (base32
> -         "1mvmz3lkr217kdrd8cvdr1d82y58wp1403c9rnd943mijgq8xb5a"))))
> +         "016h4bqg419p6s7bcx55q5iik91gqmk26hbnfgj2j6zl0j36w51r"))))

It’s weird that the content hash differs.  Did you try to diff the hg
checkout and the Git checkout?

Thanks,
Ludo’.
Ludovic Courtès Nov. 21, 2019, 9:13 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> skribis:

>> -       (method url-fetch)
>> -       (uri (string-append "https://bitbucket.org/khinsen/"
>> -                           "nmoldyn3/downloads/nMOLDYN-"
>> -                           version ".tar.gz"))
>> +       (method git-fetch)
>> +       (uri (git-reference
>> +             (url "https://github.com/khinsen/nMOLDYN3")
>> +             (commit (string-append "v" version))))
>> +       (file-name (git-file-name name version))
>>         (sha256
>>          (base32
>> -         "1mvmz3lkr217kdrd8cvdr1d82y58wp1403c9rnd943mijgq8xb5a"))))
>> +         "016h4bqg419p6s7bcx55q5iik91gqmk26hbnfgj2j6zl0j36w51r"))))
>
> It’s weird that the content hash differs.  Did you try to diff the hg
> checkout and the Git checkout?

Oh forget it, I see we’re going from a tarball to a checkout, hence the
difference.

LGTM!  :-)
diff mbox series

Patch

diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index b6345b9d27..3bdd406a47 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -243,13 +243,14 @@  analogy is that InChI is the bar-code for chemistry and chemical structures.")
     (version "3.0.11")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://bitbucket.org/khinsen/"
-                           "nmoldyn3/downloads/nMOLDYN-"
-                           version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/khinsen/nMOLDYN3")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1mvmz3lkr217kdrd8cvdr1d82y58wp1403c9rnd943mijgq8xb5a"))))
+         "016h4bqg419p6s7bcx55q5iik91gqmk26hbnfgj2j6zl0j36w51r"))))
     (build-system python-build-system)
     (inputs
      `(("python-matplotlib" ,(with-numpy-1.8 python2-matplotlib))