diff mbox series

[bug#38436] gnu: Add gfortran-toolchain

Message ID m18sngfktg.fsf@khs-macbook.home
State Accepted
Headers show
Series [bug#38436] gnu: Add gfortran-toolchain | expand

Commit Message

Konrad Hinsen Dec. 13, 2019, 12:53 p.m. UTC
* gnu/packages/commencement.scm: (gfortran-toolchain): New variable.
---
 gnu/packages/commencement.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

Jonathan Brielmaier Dec. 13, 2019, 12:56 p.m. UTC | #1
On 13.12.19 13:53, Konrad Hinsen wrote:
> * gnu/packages/commencement.scm: (gfortran-toolchain): New variable.
> ---
>   gnu/packages/commencement.scm | 13 +++++++++++++
>   1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
> index 68030376fc..541dedce0d 100644
> --- a/gnu/packages/commencement.scm
> +++ b/gnu/packages/commencement.scm
> @@ -2601,4 +2601,17 @@ an  d binaries, plus debugging symbols in the @code{debug} output), and Binutils
>   (define-public gcc-toolchain-9
>     (make-gcc-toolchain gcc-9))
>
> +;; Provide the Fortran toolchain package only for the version of gfortran that
> +;; is used by Guix intenally to build Fortran libraries, because combining

                       ^  internally
Ludovic Courtès Dec. 14, 2019, 11:22 p.m. UTC | #2
Hi,

Konrad Hinsen <konrad.hinsen@fastmail.net> skribis:

> * gnu/packages/commencement.scm: (gfortran-toolchain): New variable.

Applied, thanks!  I fixed that typo that Jonathan reported.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 68030376fc..541dedce0d 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2601,4 +2601,17 @@  an  d binaries, plus debugging symbols in the @code{debug} output), and Binutils
 (define-public gcc-toolchain-9
   (make-gcc-toolchain gcc-9))
 
+;; Provide the Fortran toolchain package only for the version of gfortran that
+;; is used by Guix intenally to build Fortran libraries, because combining
+;; code compiled with different versions can cause problems.
+
+(define-public gfortran-toolchain
+  (package (inherit (make-gcc-toolchain gfortran))
+    (synopsis "Complete GCC tool chain for Fortran development")
+    (description "This package provides a complete GCC tool chain for
+Fortran development to be installed in user profiles.  This includes
+gfortran, as well as libc (headers and binaries, plus debugging symbols
+in the @code{debug} output), and binutils.")))
+
+
 ;;; commencement.scm ends here