diff mbox series

[bug#38292] gnu: python2-mmtk: Update to 2.7.12.

Message ID m14kyz6k6v.fsf@khs-macbook.home
State Accepted
Headers show
Series [bug#38292] gnu: python2-mmtk: Update to 2.7.12. | expand

Commit Message

Konrad Hinsen Nov. 19, 2019, 6:52 p.m. UTC
* gnu/packages/python-xyz.scm (python2-mmtk): Update to 2.7.12.
---
 gnu/packages/python-xyz.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

Comments

Ludovic Courtès Nov. 21, 2019, 10:13 a.m. UTC | #1
Konrad Hinsen <konrad.hinsen@fastmail.net> skribis:

> * gnu/packages/python-xyz.scm (python2-mmtk): Update to 2.7.12.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8dbbb40893..c7299d35f1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14657,16 +14657,17 @@  not actively maintained and works only with Python 2 and NumPy < 1.9.")
 (define-public python2-mmtk
   (package
     (name "python2-mmtk")
-    (version "2.7.11")
+    (version "2.7.12")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://bitbucket.org/khinsen/"
-                           "mmtk/downloads/MMTK-" version ".tar.gz"))
-       (file-name (string-append "MMTK-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/khinsen/MMTK")
+             (commit (string-append "rel" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1d0nnjx4lwsvh8f99vv1r6gi50d93yba0adkz8b4zgv4za4c5862"))))
+         "1fqwh3ba9jd42nigvn5shndgwb1zy7kh9520ncvqci7n8ffjr6p1"))))
     (build-system python-build-system)
     (native-inputs
      `(("netcdf" ,netcdf)))