diff mbox series

[bug#43449] gnu: Add python-requests-ftp.

Message ID m14knxzrii.fsf@khs-macbook.home
State Accepted
Headers show
Series [bug#43449] gnu: Add python-requests-ftp. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Konrad Hinsen Sept. 16, 2020, 3:10 p.m. UTC
* gnu/packages/python-web.scm (python-requests-ftp): New variable.
---
 gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Konrad Hinsen Sept. 17, 2020, 7:26 a.m. UTC | #1
I forgot to pass this through lint - new patch following,
with minor fixes in synopsis and home page.

Konrad.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7926539233..b75accccac 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2029,6 +2029,28 @@  with python-requests.")
      `(;; FIXME: Some tests require network access.
        #:tests? #f))))
 
+(define-public python-requests-ftp
+  (package
+    (name "python-requests-ftp")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "requests-ftp" version))
+       (sha256
+        (base32
+         "0yh5v21v36dsjsgv4y9dx4mmz35741l5jf6pbq9w19d8rfsww13m"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-requests" ,python-requests)))
+    (home-page
+     "http://github.com/Lukasa/requests-ftp")
+    (synopsis "FTP Transport Adapter for Requests.")
+    (description
+     "Requests-FTP is an implementation of a simple FTP transport
+adapter for use with the Requests library.")
+    (license license:asl2.0)))
+
 (define-public python-oauthlib
   (package
     (name "python-oauthlib")