diff mbox series

[bug#50170,core-updates-frozen] gnu: mesa: Update to 21.2.1.

Message ID lyT-dRra1A3lt7VRTvpG1Qj4zr0STz--KCtLv3e__Zl24xuNoKr2U3GYaE5Axget9JYGxeumrHpn5WU61MS_HnUzTn0lgJD52gH_KkiRxMw=@protonmail.com
State Accepted
Headers show
Series [bug#50170,core-updates-frozen] gnu: mesa: Update to 21.2.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Aug. 23, 2021, 5:50 a.m. UTC
* gnu/packages/gl.scm (mesa): Update to 21.2.1.
* gnu/packages/patches/mesa-skip-tests.patch: Modify for current version.
---
 gnu/packages/gl.scm                        |  4 ++--
 gnu/packages/patches/mesa-skip-tests.patch | 28 +++++++---------------
 2 files changed, 11 insertions(+), 21 deletions(-)

--
2.33.0

Comments

John Kehayias Aug. 23, 2021, 5:58 a.m. UTC | #1
Hi everyone,

I know we're working on getting core-updates-frozen in shape to merge, but with a few more Mesa updates out recently I thought maybe I can sneak this in as an addendum to the current Mesa patches. I checked it builds on x86-64 and modified the patch which removes the troublesome (i686) test to still apply here. No other changes to the build process I could see. 21.2.0 was out earlier but was a development release; this is the first regular release for 21.2.

If I may, I would suggest seeing if this builds on the CI for other architectures without major changes, and if so would recommend this update. Mesa has been moving quickly with bug fixes and enhancing their graphics drivers, so with the extended time between core-update merges would be great to be up to date for this current merge.

And if not, this can be the start of the next core-updates Mesa update (maybe Mesa can be moved to a quicker updating process?). There is also a further bug fix release for 21.1, so we could bump to 21.1.7 from our current 21.1.6 in core-updates-frozen.

Let me know what you think and anything else we need on this front.

John
Maxim Cournoyer Oct. 15, 2021, 12:42 a.m. UTC | #2
Hi!

John Kehayias <john.kehayias@protonmail.com> writes:

> * gnu/packages/gl.scm (mesa): Update to 21.2.1.
> * gnu/packages/patches/mesa-skip-tests.patch: Modify for current version.
> ---
>  gnu/packages/gl.scm                        |  4 ++--
>  gnu/packages/patches/mesa-skip-tests.patch | 28 +++++++---------------
>  2 files changed, 11 insertions(+), 21 deletions(-)
>
> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
> index 7a8a478953..d6e754779d 100644
> --- a/gnu/packages/gl.scm
> +++ b/gnu/packages/gl.scm
> @@ -239,7 +239,7 @@ also known as DXTn or DXTC) for Mesa.")
>  (define-public mesa
>    (package
>      (name "mesa")
> -    (version "21.1.6")
> +    (version "21.2.1")
>      (source
>        (origin
>          (method url-fetch)
> @@ -251,7 +251,7 @@ also known as DXTn or DXTC) for Mesa.")
>                                    version "/mesa-" version ".tar.xz")))
>          (sha256
>           (base32
> -          "0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
> +          "11qpq16xbxymcgiy0wk787dk4yw2pv8fzgj8d92ng6s11dqycr9c"))
>          (patches
>           (search-patches "mesa-skip-tests.patch"))))
>      (build-system meson-build-system)
> diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
> index 8f587ea7ef..0813fa2a8a 100644
> --- a/gnu/packages/patches/mesa-skip-tests.patch
> +++ b/gnu/packages/patches/mesa-skip-tests.patch
> @@ -5,25 +5,15 @@ completely with this patch:
>  https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
>
>  diff --git a/src/util/meson.build b/src/util/meson.build
> -index 0893f64..909b3e0 100644
> +index aa5bfef5dbc..3ec845b05fa 100644
>  --- a/src/util/meson.build
>  +++ b/src/util/meson.build
> -@@ -289,18 +289,6 @@ if with_tests
> -      suite : ['util'],
> -   )
> +@@ -344,7 +344,7 @@ if with_tests
> +     )
> +   endif
>
> --  test(
>
> --    'u_debug_stack',
> --    executable(
> --      'u_debug_stack_test',
> --      files('u_debug_stack_test.cpp'),
> --      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
> --      dependencies : [idep_mesautil, idep_gtest],
> --      c_args : [c_msvc_compat_args],
> --    ),
> --     suite : ['util'],
> --  )
> --
> -   process_test_exe = executable(
> -     'process_test',
> -     files('process_test.c'),
> +-  foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
> ++  foreach t: ['bitset', 'register_allocate', 'u_qsort']
> +     test(
> +       t,
> +       executable(
> --
> 2.33.0

I wanted to apply this to my batched local core-updates-frozen branch,
but I get:

error: corrupt patch at line 69

Could you please resend it?

Thanks!

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7a8a478953..d6e754779d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -239,7 +239,7 @@  also known as DXTn or DXTC) for Mesa.")
 (define-public mesa
   (package
     (name "mesa")
-    (version "21.1.6")
+    (version "21.2.1")
     (source
       (origin
         (method url-fetch)
@@ -251,7 +251,7 @@  also known as DXTn or DXTC) for Mesa.")
                                   version "/mesa-" version ".tar.xz")))
         (sha256
          (base32
-          "0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
+          "11qpq16xbxymcgiy0wk787dk4yw2pv8fzgj8d92ng6s11dqycr9c"))
         (patches
          (search-patches "mesa-skip-tests.patch"))))
     (build-system meson-build-system)
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 8f587ea7ef..0813fa2a8a 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -5,25 +5,15 @@  completely with this patch:
 https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091

 diff --git a/src/util/meson.build b/src/util/meson.build
-index 0893f64..909b3e0 100644
+index aa5bfef5dbc..3ec845b05fa 100644
 --- a/src/util/meson.build
 +++ b/src/util/meson.build
-@@ -289,18 +289,6 @@ if with_tests
-      suite : ['util'],
-   )
+@@ -344,7 +344,7 @@ if with_tests
+     )
+   endif

--  test(
--    'u_debug_stack',
--    executable(
--      'u_debug_stack_test',
--      files('u_debug_stack_test.cpp'),
--      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
--      dependencies : [idep_mesautil, idep_gtest],
--      c_args : [c_msvc_compat_args],
--    ),
--     suite : ['util'],
--  )
--
-   process_test_exe = executable(
-     'process_test',
-     files('process_test.c'),
+-  foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
++  foreach t: ['bitset', 'register_allocate', 'u_qsort']
+     test(
+       t,
+       executable(