diff mbox series

[bug#50100] gnu: Add python-android-otp-extractor.

Message ID l4q8DY_8EToPgmIVnrJvO5HfvEVzDuhR1q9cpQ9DcYaGlk76nAY5UjcYh-fl8KmzH44NQRpnwPFAqHNlbxToTflMvpwppu3Ijs8eOB3NGGY=@protonmail.com
State New
Headers show
Series [bug#50100] gnu: Add python-android-otp-extractor. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Aug. 17, 2021, 7:51 p.m. UTC
* gnu/packages/android.scm (python-android-otp-extractor): New variable.

--
2.32.0
diff mbox series

Patch

diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index eb538f6540..5510aa6a29 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -916,6 +916,36 @@  safest way, on a file image.")
 useful for reverse engineering, analysis of Android applications and more.")
     (license license:asl2.0)))

+(define-public python-android-otp-extractor
+(package
+  (name "python-android-otp-extractor")
+  (version "cf282c71b178faa893aacf70b46ba9a78e694c86") ; no tags
+  (source
+   (origin
+    (method git-fetch)
+     (uri
+      (git-reference
+       (url "https://github.com/puddly/android-otp-extractor")
+       (commit version)))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32
+       "05la9rms7vgzpgk0qhhwqzsdggdnakgppdpp1wm2pzcg7rn8yp21"))))
+  (build-system python-build-system)
+  (arguments
+    `(#:tests? #f)) ; no tests
+  (propagated-inputs `(("adb" ,adb)
+                       ("python-cryptography" ,python-cryptography)
+                       ("python-coloredlogs" ,python-coloredlogs)))
+  (synopsis "Extracts OTP tokens from rooted Android devices")
+  (description "Many OTP apps don't support exporting or backing up their OTP
+secrets.  Switching apps would require you to regenerate all of your tokens,
+which can be tedious if you have a lot.  This application can extract your
+tokens from popular Android OTP apps and export them in a standard format
+or just display them as QR codes for easy importing.")
+  (home-page "https://github.com/puddly/android-otp-extractor")
+  (license license:gpl3)))
+
 (define-public fdroidserver
   (package
     (name "fdroidserver")