diff mbox series

[bug#52530,core-updates-frozen] WIP: Add rust-gtk4 and dependencies

Message ID l4lPDuK3_trOISY7LCmf-1NqZ-GeWRd7c9xDauGMVqv2folgXCevIOlDHYGdXHKe22OekRnwzdfb1qAbpS7d9hRsMoJQVgSCnQesHmL2g7o=@protonmail.ch
State New
Headers show
Series [bug#52530,core-updates-frozen] WIP: Add rust-gtk4 and dependencies | expand

Commit Message

Nicholas von Klitzing Dec. 15, 2021, 11:05 p.m. UTC
Hello Guix!

These are my WIP patches to add the gtk4 crates. Several Gnome and Gtk applications depend on this crate (Authenticator, Fractal, Shortwave, etc).

I based the patches on c-u-f because the master branch isn't building on my machine for unrelated reasons I have yet to explore. Regardless, there should be no conflicts.

Several of the dependency package definitions are unedited from `guix import`, so please do let me know if you think I should change them.

Looking forward to your feedback!

Kind regards,
Nicholas von Klitzing

Comments

Maxim Cournoyer Dec. 19, 2021, 4:42 a.m. UTC | #1
Hi Nicholas,

Nicholas von Klitzing <nicholas@nvk.pm> writes:

> Hello Guix!
>
> These are my WIP patches to add the gtk4 crates. Several Gnome and Gtk applications depend on this crate (Authenticator, Fractal, Shortwave, etc).
>
> I based the patches on c-u-f because the master branch isn't building on my machine for unrelated reasons I have yet to explore. Regardless, there should be no conflicts.
>
> Several of the dependency package definitions are unedited from `guix import`, so please do let me know if you think I should change them.

Yes, the packages need a proper synopsis and description (stylized with
Texinfo) for inclusion.  Make sure 'guix lint' is happy with them as
well, and have a read at info '(guix)Contributing', particularly the
'Synopses andDescriptions' subsection.

Thank you!

Maxim
Nicholas von Klitzing Jan. 8, 2022, 9:10 a.m. UTC | #2
Hi Maxim,

I was looking reading through the Guix Contributing guide and found that several of the recommendations are not being used by many packages.

For example, many of the packaged rust crates only have a one-line synopsis and a one-line description, where the description is basically just the synopsis with a few extra verbs added.

Is the style mentioned above acceptable or would you recommend I do something else?

Best,
Nicholas

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Sunday, December 19th, 2021 at 4:42 AM, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

> Hi Nicholas,
>
> Nicholas von Klitzing nicholas@nvk.pm writes:
>
> > Hello Guix!
> >
> > These are my WIP patches to add the gtk4 crates. Several Gnome and Gtk applications depend on this crate (Authenticator, Fractal, Shortwave, etc).
> >
> > I based the patches on c-u-f because the master branch isn't building on my machine for unrelated reasons I have yet to explore. Regardless, there should be no conflicts.
> >
> > Several of the dependency package definitions are unedited from `guix import`, so please do let me know if you think I should change them.
>
> Yes, the packages need a proper synopsis and description (stylized with
>
> Texinfo) for inclusion. Make sure 'guix lint' is happy with them as
>
> well, and have a read at info '(guix)Contributing', particularly the
>
> 'Synopses andDescriptions' subsection.
>
> Thank you!
>
> Maxim
diff mbox series

Patch

From 1b5b51a56b49e73580e8bf8b625872bb4c3f34d5 Mon Sep 17 00:00:00 2001
From: Nicholas von Klitzing <nicholas@nvk.pm>
Date: Wed, 15 Dec 2021 23:45:26 +0100
Subject: [PATCH 08/29] gnu: Add rust-system-deps-5.

* gnu/packages/crates-gtk.scm (rust-system-deps-5): New variable.
---
 gnu/packages/crates-gtk.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 5a2a75121e..6a05257c89 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1070,6 +1070,34 @@  (define-public rust-cfg-expr-0.9
       "This package provides a parser and evaluator for Rust `cfg()` expressions.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-system-deps-5
+  (package
+    (name "rust-system-deps")
+    (version "5.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "system-deps" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "0zkrf58z96y3f5ggglqirc97iy9rvyippkq67vkx0yyvaiaqbnqq"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-cfg-expr" ,rust-cfg-expr-0.9)
+         ("rust-heck" ,rust-heck-0.3)
+         ("rust-pkg-config" ,rust-pkg-config-0.3)
+         ("rust-toml" ,rust-toml-0.5)
+         ("rust-version-compare" ,rust-version-compare-0.0))))
+    (home-page "https://github.com/gdesmott/system-deps")
+    (synopsis
+      "Discover and configure system dependencies from declarative dependencies in Cargo.toml")
+    (description
+      "Discover and configure system dependencies from declarative dependencies in Cargo.toml")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gtk-0.8
   (package
     (name "rust-gtk")
-- 
2.34.0