diff mbox series

[bug#47751] gnu: Add seatd.

Message ID kg70plrfIYk953CSJvLS-mK18mf3Fct93nx9fLjUB2CZvhfRfWfnYOa2MtLBPpmvNDBePVSxZtPTAZfg8E-W_w2fMZnzMU5jAf_ANmDub_0=@protonmail.com
State Accepted
Headers show
Series [bug#47751] gnu: Add seatd. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

guixuser6392 April 13, 2021, 1:45 p.m. UTC
Hello, Guix!

This patch adds a single package definition for a minimal seat management daemon (seatd), and a universal seat management library (libseat), under the name of `seatd'.

Regards,
pineapples

Comments

guixuser6392 April 13, 2021, 1:57 p.m. UTC | #1
Hello,

I have accidentally sent my patch twice. May someone please close this duplicate ticket?

I am sorry for this.

Regards,
pineapples
M April 13, 2021, 5:57 p.m. UTC | #2
On Tue, 2021-04-13 at 13:57 +0000, guixuser6392 via Guix-patches via wrote:
> Hello,
> 
> I have accidentally sent my patch twice. May someone please close this duplicate ticket?
Closed.  You can close issues yourself by writing
a mail to BUGNUMBER-done@debbugs.gnu.org

There's information on debbugs here: <https://debbugs.gnu.org/server-control.html>
and <https://debbugs.gnu.org/server-refcard.html>.

Greetings,
Maxime.
Tobias Geerinckx-Rice April 13, 2021, 6:15 p.m. UTC | #3
Hi,

It's better to merge identical bugs than to keep duplicates in 
potentially different states (‘is The Seatd Bug open or closed?’ 
‘both’).

I merged them by sending

  merge 47750 47751

to control@debbugs.gnu.org.

Both numbers effectively refer to the same bug after that, so 
closing 47751 did not have the effect you expected.  I've reopened 
it.

Kind regards,

T G-R
M April 13, 2021, 7:45 p.m. UTC | #4
On Tue, 2021-04-13 at 20:15 +0200, Tobias Geerinckx-Rice wrote:
> Hi,
> 
> It's better to merge identical bugs than to keep duplicates in 
> potentially different states (‘is The Seatd Bug open or closed?’ 
> ‘both’).
> 
> I merged them by sending
> 
>   merge 47750 47751
> 
> to control@debbugs.gnu.org.
> 
> Both numbers effectively refer to the same bug after that, so 
> closing 47751 did not have the effect you expected.

I noticed, and tried to reopen the bug, but I sent the mail to the
reopened the wrong bug (#47551) -- actually a no-op, since that bug
was already open.

Greetings,
Maxime.
Tobias Geerinckx-Rice April 13, 2021, 7:54 p.m. UTC | #5
Maxime,

Thanks for clearing that up!

Make sure to remove -done from the bug address when replying[0].

Kind regards,

T G-R

[0]: https://logs.guix.gnu.org/guix/2021-04-13.log#212711
guixuser6392 May 1, 2021, 1:22 p.m. UTC | #6
I would like to ask patch reviewers and those with commit access to not accept this patch as-is, as I will be migrating to an email-driven git workflow friendly email provider in the upcoming days, and I want the new email address to be used instead.

I will update the patch as soon as the migration is complete.

Regards,
pineapples
Ludovic Courtès May 14, 2021, 10:44 a.m. UTC | #7
Hi,

guixuser6392 <guixuser6392@protonmail.com> skribis:

> From 6dce6e93197bd911e136e345a7d6acfe711ecef3 Mon Sep 17 00:00:00 2001
> From: pineapples <guixuser6392@protonmail.com>
> Date: Tue, 13 Apr 2021 15:12:53 +0200
> Subject: [PATCH] gnu: Add seatd.
>
> * gnu/packages/freedesktop.scm (seatd): New variable.

Finally applied, thanks!

Ludo’.
diff mbox series

Patch

From 6dce6e93197bd911e136e345a7d6acfe711ecef3 Mon Sep 17 00:00:00 2001
From: pineapples <guixuser6392@protonmail.com>
Date: Tue, 13 Apr 2021 15:12:53 +0200
Subject: [PATCH] gnu: Add seatd.

* gnu/packages/freedesktop.scm (seatd): New variable.
---
 gnu/packages/freedesktop.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 40d41350ac..36002fcf04 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -825,6 +826,36 @@  GNOME Shell.  The @command{localectl} command-line tool allows you to interact
 with localed.  This package is extracted from the broader systemd package.")
     (license license:lgpl2.1+)))
 
+(define-public seatd
+  (package
+    (name "seatd")
+    (version "0.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~kennylevinsen/seatd")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1kglq8v4rnr3415mfaghyv2s2f8mxsy5s881gmm2908ig4n4j297"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags '("-Dlogind=enabled")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("scdoc" ,scdoc)))
+    (inputs
+     `(("elogind" ,elogind)))
+    (home-page "https://sr.ht/~kennylevinsen/seatd")
+    (synopsis "Seat management daemon and library")
+    (description
+     "This package provides a minimal seat management daemon whose task is to
+mediate access to shared devices, such as graphics and input, for applications
+that require it.  It also provides a universal seat management library that
+allows applications to use whatever seat management is available.")
+    (license license:expat)))
+
 (define-public packagekit
   (package
     (name "packagekit")
-- 
2.31.1