@@ -5834,32 +5834,3 @@ (define-public odio-sacd
and DSD streams.")
(home-page "https://tari.in/www/software/odio-sacd/")
(license license:gpl3+)))
-
-(define-public qpwgraph
- (package
- (name "qpwgraph")
- (version "0.3.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.freedesktop.org/rncbc/qpwgraph")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xqmlbqj6ny4cpclzr8xyy6d6i392h9f1vmlbasp6xfy5b0yya94"))))
- (build-system cmake-build-system)
- (arguments (list #:tests? #f)) ;; no tests
- (inputs (list alsa-lib
- libxkbcommon
- pipewire-0.3
- qtbase
- qtsvg))
- (native-inputs (list pkg-config))
- (synopsis "PipeWire graph manager")
- (description
- "qpwgraph is a graph manager dedicated to PipeWire, using the Qt C++
-framework. It provides a visual interface to audio and video connections
-managed by PipeWire.")
- (home-page "https://gitlab.freedesktop.org/rncbc/qpwgraph")
- (license license:gpl2)))
@@ -8788,36 +8788,6 @@ (define-public pipewire-0.3
vulkan-loader
vulkan-headers)))))
-(define-public wireplumber
- (package
- (name "wireplumber")
- (version "0.4.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url
- "https://gitlab.freedesktop.org/pipewire/wireplumber.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0g7xkgkjlxrhs49hqkwrjk2hb478gq55wwydafvvbsv78vsa7qfb"))))
- (build-system meson-build-system)
- (arguments
- `(#:configure-flags '("-Dsystemd=disabled"
- "-Dsystem-lua=true")))
- (native-inputs
- (list `(,glib "bin")
- pkg-config))
- (inputs (list dbus elogind glib lua pipewire-0.3))
- (home-page "https://gitlab.freedesktop.org/pipewire/wireplumber")
- (synopsis "Session / policy manager implementation for PipeWire")
- (description "WirePlumber is a modular session / policy manager for
-PipeWire and a GObject-based high-level library that wraps PipeWire's API,
-providing convenience for writing the daemon's modules as well as external
-tools for managing PipeWire.")
- (license license:expat)))
-
(define-public ell
(package
(name "ell")
@@ -1,4 +1,10 @@
+;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
+;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Juliana Sims <jtsims@protonmail.com>
;;; Copyright © 2022 Marcel Kupiec <formbi@protonmail.com>
+;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +52,65 @@ (define-module (gnu packages pipewire)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xiph))
+(define-public wireplumber
+ (package
+ (name "wireplumber")
+ (version "0.4.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://gitlab.freedesktop.org/pipewire/wireplumber.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g7xkgkjlxrhs49hqkwrjk2hb478gq55wwydafvvbsv78vsa7qfb"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags '("-Dsystemd=disabled"
+ "-Dsystem-lua=true")))
+ (native-inputs
+ (list `(,glib "bin")
+ pkg-config))
+ (inputs (list dbus elogind glib lua pipewire-0.3))
+ (home-page "https://gitlab.freedesktop.org/pipewire/wireplumber")
+ (synopsis "Session / policy manager implementation for PipeWire")
+ (description "WirePlumber is a modular session / policy manager for
+PipeWire and a GObject-based high-level library that wraps PipeWire's API,
+providing convenience for writing the daemon's modules as well as external
+tools for managing PipeWire.")
+ (license license:expat)))
+
+(define-public qpwgraph
+ (package
+ (name "qpwgraph")
+ (version "0.3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xqmlbqj6ny4cpclzr8xyy6d6i392h9f1vmlbasp6xfy5b0yya94"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;; no tests
+ (inputs (list alsa-lib
+ libxkbcommon
+ pipewire-0.3
+ qtbase
+ qtsvg))
+ (native-inputs (list pkg-config))
+ (synopsis "PipeWire graph manager")
+ (description
+ "qpwgraph is a graph manager dedicated to PipeWire, using the Qt C++
+framework. It provides a visual interface to audio and video connections
+managed by PipeWire.")
+ (home-page "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+ (license license:gpl2)))
+
(define-public easyeffects
(let ((toolchain (specification->package "gcc-toolchain@11")))
;; for std::source_location
Sorry, the commit got mixed up with the previous changes, I hope it's ok now: From e006cfc3d81cb19e64d62cee84db7a042aceae74 Mon Sep 17 00:00:00 2001 From: Formbi <formbi@protonmail.com> Date: Mon, 15 Aug 2022 13:31:27 +0200 Subject: [PATCH] gnu: Move wireplumber and qpwgraph to pipewire.scm. * gnu/packages/pipewire.scm: Move wireplumber and qpwgraph. * gnu/packages/linux.scm: Remove wireplumber. * gnu/packages/audio.scm: Remove qpwgraph. --- gnu/packages/audio.scm | 29 ----------------- gnu/packages/linux.scm | 30 ------------------ gnu/packages/pipewire.scm | 65 +++++++++++++++++++++++++++++++++++++++ 3 files changed, 65 insertions(+), 59 deletions(-) -- 2.37.0