diff mbox series

[bug#40102] gnu packages gnome-xyz: Add topicons-redux

Message ID jxwfI4XONO2CyyrY3UJHHq8_WLo74QEA_j4O2AqjC-dTnXe6ViWiIJctAJjvMY8n_doI8hoDerTJ98kip7GyJ47tXi_XMEdtegymVZfGlSc=@elenq.tech
State Accepted
Headers show
Series [bug#40102] gnu packages gnome-xyz: Add topicons-redux | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Ekaitz Zarraga March 17, 2020, 4:55 p.m. UTC
> Hi Ekaitz,
>
> > -   (home-page
> > -        "https://gitlab.com/pop-planet/TopIcons-Redux/-/tree/master";)
> >
> >
>
> You should probably drop "-/tree/master" and uncomment the bracket.
> Otherwise LGTM.
>
> Regards,
> Leo

The comment was accidentally introduced in the email. I don't really know how tbh.

Thanks for the comment, here's the updated patch:



From 4bbe7c5061a04d07ad9b85ff63d32379f34f8dc8 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 17 Mar 2020 13:54:24 +0100
Subject: [PATCH] gnu packages gnome-xyz: Add topicons-redux

---
 gnu/packages/gnome-xyz.scm | 48 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)

--
2.25.1

Comments

Marius Bakke March 20, 2020, 5:53 p.m. UTC | #1
Ekaitz Zarraga <ekaitz@elenq.tech> writes:

> From 4bbe7c5061a04d07ad9b85ff63d32379f34f8dc8 Mon Sep 17 00:00:00 2001
> From: Ekaitz Zarraga <ekaitz@elenq.tech>
> Date: Tue, 17 Mar 2020 13:54:24 +0100
> Subject: [PATCH] gnu packages gnome-xyz: Add topicons-redux

[...]

> +(define-public gnome-shell-extension-topicons-redux
> +  (package
> +    (name "gnome-shell-extension-topicons-redux")
> +    (version "6")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri
> +          (string-append
> +            "https://gitlab.com/pop-planet/TopIcons-Redux/-/archive/"
> +            version "/TopIcons-Redux-" version ".tar.gz"))

Such "autogenerated" tarballs from GitLab and GitHub are prone to
getting re-created with different time stamps, breaking the checksum.
Can you adjust this package to use git-fetch instead of url-fetch?

[...]

> +    (arguments
> +      `(#:tests? #f

Why are tests disabled?  Please leave a comment.

> +        #:phases
> +        (modify-phases
> +          %standard-phases
> +          (delete 'configure)
> +          (delete 'build)
> +          (replace 'install
> +                   (lambda* (#:key outputs #:allow-other-keys)
> +                            (let ((out (assoc-ref outputs "out")))
> +                              (invoke "make"
> +                                      "install"
> +                                      (string-append
> +                                        "INSTALL_PATH="
> +                                        out
> +                                        "/share/gnome-shell/extensions"))))))))

Indentation is off here.  If you are not using Emacs there is a script
that can help with indentation, see "Formatting Code" in the Guix manual.

> +
> +    (home-page
> +      "https://gitlab.com/pop-planet/TopIcons-Redux/")

The line break here is not necessary.

> +    (synopsis "Displays legacy tray icons in the GNOME Shell top panel.
> +Rewritten fork of TopIcons Plus.")

Please keep synopsis to single sentences.  The second sentence can be
removed IMO.

> +    (description "Many applications, such as chat clients, downloaders, and
> +some media players, are meant to run long-term in the background even after you
> +close their window. These applications remain accessible by adding an icon to
> +the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
> +3.26. TopIcons Redux brings those icons back into the top panel so that it's
> +easier to keep track of apps running in the
> +backround.")

'guix lint gnome-shell-extension-topicons-redux' will warn that
sentences should be separated by two spaces.  Can you adjust accordingly?

> +    (license license:gpl2)))

Is the license really GPL2 only?  Unless the source code says explicitly
"GPL2 only", this should probably be "gpl2+", i.e. "GPL2 or any later
version".

Can you send an updated patch?

TIA!
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b8cd32db08..abb8dab4f7 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,6 +27,7 @@ 
   #:use-module (guix build-system copy)
   #:use-module (guix build-system meson)
   #:use-module (guix git-download)
+  #:use-module (guix download)
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages base)
@@ -146,6 +148,52 @@  GNOME Shell.")
     (home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
     (license license:gpl2+)))

+(define-public gnome-shell-extension-topicons-redux
+  (package
+    (name "gnome-shell-extension-topicons-redux")
+    (version "6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri
+          (string-append
+            "https://gitlab.com/pop-planet/TopIcons-Redux/-/archive/"
+            version "/TopIcons-Redux-" version ".tar.gz"))
+        (sha256
+          (base32 "0diwb6l4wy4dwpwkls4cq8v0dbi99q194jfl39sv7f7mnbjjgi82"))))
+    (build-system gnu-build-system)
+    (native-inputs
+      `(("glib" ,glib "bin")))
+    (arguments
+      `(#:tests? #f
+        #:phases
+        (modify-phases
+          %standard-phases
+          (delete 'configure)
+          (delete 'build)
+          (replace 'install
+                   (lambda* (#:key outputs #:allow-other-keys)
+                            (let ((out (assoc-ref outputs "out")))
+                              (invoke "make"
+                                      "install"
+                                      (string-append
+                                        "INSTALL_PATH="
+                                        out
+                                        "/share/gnome-shell/extensions"))))))))
+
+    (home-page
+      "https://gitlab.com/pop-planet/TopIcons-Redux/")
+    (synopsis "Displays legacy tray icons in the GNOME Shell top panel.
+Rewritten fork of TopIcons Plus.")
+    (description "Many applications, such as chat clients, downloaders, and
+some media players, are meant to run long-term in the background even after you
+close their window. These applications remain accessible by adding an icon to
+the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
+3.26. TopIcons Redux brings those icons back into the top panel so that it's
+easier to keep track of apps running in the
+backround.")
+    (license license:gpl2)))
+
 (define-public gnome-shell-extension-dash-to-dock
   (package
     (name "gnome-shell-extension-dash-to-dock")